Mail and FTP doesn´t work

Discussion in 'Installation/Configuration' started by cyprus, Apr 16, 2012.

  1. cyprus

    cyprus New Member

    Hello,
    I try to get ISPConfig 3 to run. But I stumble over E-Mail and FTP

    My config is: Debian Squeeze, Nginx, MySQL 5.5, Pureftp Bind Postfix & Dovecot
    I used the Perfect Server tut and everything seems to be fine. The setup of IspConfig3 worked like a charm everything is up and seems to run, but I can´t connect via FTP. Filezilla gives me this message:
    I turned VERBOSE on and got this message:

    And the log for the mail gives me this info:
    After searching the web for a week. Reading every single post about such issues I ran out of ideas and need help.

    Thank you in advance
    Cyprus
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check that you used the full ftp username incl. prefix as it gets displayed in the FTP user list in ispconfig (not the details page).

    If thats ok, check if the mysql username and password that you find in the pure-ftpd sql config gile are correct (e.g. by entering them into phpmyadmin).

    Then check if the ftp user directory exists ( /var/www/yourdomain.tld/ ).
     
  3. cyprus

    cyprus New Member

    Thanx for your reply.
    I checked the name before cause this seems to be a common mistake. And the user name is prefix and user so it seems to be okay.

    The path is /var/www/clients/client1/web1 but there are symlinks in var/www with the domains to the clients

    The heck after the installation of squirrelmail I can´t phpmyadmin https://domain.tls:8080/phpmyadmin and all equvalants don´t work

    Good night

    Cyprus
     
  4. deskartez

    deskartez New Member

    Pure-FTP needs additional setup for ISPconfig3

    I also followed the tutorial for ISPconfig3 and read the manual, but could not get ftp to work. Pure-FTP works on my system after following the following howtoforge tutorial http://www.howtoforge.com/virtual-h...ota-and-bandwidth-management-on-centos-6.2-p2.

    I can login to a newly created ftp account with filezilla or from the commandline with no problems.

    I think that maybe pure-ftp's mysql config file needs to be setup to use the ftp-users table from dbispconfig (ispconfig's mysql database). Also the user and group ID's for pure-ftp maybe should be set to ispconfig.

    I checked the ftp_users table in dbispconfig and it has an entry added for an ftp user associated with a client and webpage. The website directories are created by ispconfig and the ispconfig ftpuser is setup with www/cleints/cleint1... however when logging on using ftp credentials created through ispconfig nothing works. Manually creating pure-ftp credentials without the use of ispconfig is a pain in the arsch but it works. I check that database table's data and it is populated and works for logging in. hmmm i'm thinking that i might change the pureftp_mysql.conf file to read from the dbispconfig database ..what the heck
     
    Last edited: Apr 17, 2012
  5. cyprus

    cyprus New Member

    Okay I fooled myself.
    After the reaktivation of phpmyadmin by deleting the squirrelmail part in the nginx vhost configuration. I logged in as ispconfig and saw a different username for the ftp login and that worked. Sorry for beeing so stupid, and bother you with such stuff.

    But the email problem is still alive. Are there any suggestion what to check. I read the topic about pam problems but I have to admit not to understand what to do.

    Thanx in advance

    Cyprus
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You use a dovecot setup and email users are authenticated by dovecot. PAM is not involved at all, so if you read something about PAM, then this is nothing that applies to your server.

    Are you sure that you used the full email address as suername and not just the part in front of the @ to authenticate the mail user? Some applications like thunderbird are a bit buggy as they strip the part after the @ whebn you create a email account and ypu have to set the full email address as username again after setting up the account.
     
  7. cyprus

    cyprus New Member

    PAM was just an idea to tear the problem into smaller pieces.
    Maybe I should describe the problem as plain as it is.
    If I setup an email user I get an Message from ISPCONFIG which tell me the useracount is ready for use.
    I don´t use the Mailbox I send the emails as cc to an existing gmail account.
    If I do so I get an reply to the sending account.

    Thats what I see here.
    By the way many thanx for your support.

    Cyprus
     
  8. cyprus

    cyprus New Member

    Okay still searching for the possible missconfiguration. I had a look at the ispconfig installation log and I saw one point:

    There seems to be problem and when I drop it into google I found a thread on this forum which point to an sasl Problem I tried to restart it but it wasn´t found and seem to be not installated. Which is strange cause it was fine when the ispconfig installation ran.

    Are there any suggestions what I should do right now?

    Thanx in advance

    Cyprus
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not strange at all as sasl is not used in your setup, see my explanations in post #6 of this thread. If sasl would be there, then you would have a problem but the absence of sasl indicates that this part of the setup is ok. Pleae be aware that there are many different types of setups and if you follow a link for a setup that is not yours, then you will find wrong answers.

    The installation notices that you posted above are not related to your problem.

    Regarding your original problem, check the mail.log agaon and post the errors that you get when you search for team@orx.org
     
  10. cyprus

    cyprus New Member

    Well in the mail log there is no entry for team@orx.org.
    I restarted the server and this is the mail.log

    Thanks Cyprus
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    If there is no entry for that domain, then the gmx server was not able to contact your server. This means that the problem is most likely outside of your server e.g. a firewall or router or postfix is not listening on the external network interface. Is the server located in a datacenter with a fixed IP address or is it hosted at home / in office on a dsl or bale line?
     
  12. cyprus

    cyprus New Member

    It´s an Hetzner Server with an own ip.

    Thank you Cyprus
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap

    and

    iptables -L

    and check the dns records for orx.org to ensure that the my record points to the hostname of your server.
     
  14. cyprus

    cyprus New Member

    netstap:
    iptables L
    Thanx
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if postfix is listening only on locahost, edit the postfix main.cf configuration file, find the inet_interface line and set it to:

    inet_interfaces = all

    then restart postfix.
     
  16. cyprus

    cyprus New Member

    YES!!! That has done the job. Mail comes in. :D:D:D

    Many thanks. Your support is great. And I love to become a subscriber but it seems to be impossible without an credit card if I wanna use paypal.


    THANK YOU!
     

Share This Page