mail - 8080 - couple of others

Discussion in 'General' started by clemens, Jun 3, 2009.

  1. clemens

    clemens New Member

    Hi all

    Got a clean install of 3.0.1.3 and have a couple of problems.

    hope you can spare some time and give a couple of hint or solutions on those problems im having, so first off ill like to thanks all for helping out, really aprisiate it.

    The first problem are:

    1. cant get the admin part, on port 8080 when using the domain in this case its "hosting.dateos.dk" but works when using the local ip in this case 192.168.0.120 - to this most say did work when i was using a diffrent gateway, change the gateway in /etc/network/interfaces and did a restart of the box

    So could it be that i need to make this change another place also?


    2. Mail problem, did not work on the other gateway as well.

    Can send mail from squrrel mail, to any account i tryed, fail to get a reply back, from those accounts, and dont get any reply back about any thing wrong just dont get any mails.

    Another thing here are that i cant get outlook to send mail using those accounts either but think its the same problem, but cant say if so.

    here is a log:

    as you can se the @newzsteam.net account got my ip but the @dateos.dk dont its using localhost ip cant see why this is.


    Jun 3 22:32:40 hosting imapd: Connection, ip=[::ffff:87.57.160.26]
    Jun 3 22:32:40 hosting imapd: LOGIN, user=maddoggy@newzsteam.net, ip=[::ffff:87.57.160.26], port=[51741], protocol=IMAP
    Jun 3 22:32:41 hosting imapd: Connection, ip=[::ffff:87.57.160.26]
    Jun 3 22:32:41 hosting imapd: LOGIN, user=maddoggy@newzsteam.net, ip=[::ffff:87.57.160.26], port=[51742], protocol=IMAP
    Jun 3 22:32:48 hosting imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:32:48 hosting imapd: LOGIN, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], port=[55998], protocol=IMAP
    Jun 3 22:32:48 hosting imapd: LOGOUT, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=30, sent=238, time=0
    Jun 3 22:32:48 hosting imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:32:48 hosting imapd: LOGIN, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], port=[55999], protocol=IMAP
    Jun 3 22:32:48 hosting imapd: LOGOUT, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=431, sent=1438, time=0
    Jun 3 22:32:48 hosting imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:32:48 hosting imapd: LOGIN, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], port=[56001], protocol=IMAP
    Jun 3 22:32:48 hosting imapd: LOGOUT, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=119, sent=900, time=0
    Jun 3 22:32:51 hosting imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:32:51 hosting imapd: LOGIN, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], port=[56003], protocol=IMAP
    Jun 3 22:32:51 hosting imapd: LOGOUT, user=tc@dateos.dk, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=119, sent=900, time=0
    Jun 3 22:33:23 hosting imapd: LOGOUT, user=maddoggy@newzsteam.net, ip=[::ffff:87.57.160.26], headers=0, body=0, rcvd=417, sent=1946, time=42
    Jun 3 22:33:23 hosting imapd: LOGOUT, user=maddoggy@newzsteam.net, ip=[::ffff:87.57.160.26], headers=0, body=0, rcvd=65, sent=376, time=43
    Jun 3 22:35:01 hosting pop3d: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:35:01 hosting pop3d: Disconnected, ip=[::ffff:127.0.0.1]
    Jun 3 22:35:01 hosting imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 3 22:35:01 hosting imapd: Disconnected, ip=[::ffff:127.0.0.1], time=0
    Jun 3 22:35:01 hosting postfix/smtpd[20063]: connect from localhost.localdomain[127.0.0.1]


    output from netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost.localdo:10024 *:* LISTEN 1850/amavisd (maste
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 32265/master
    tcp 0 0 *:mysql *:* LISTEN 1914/mysqld
    tcp 0 0 localhost.localdoma:781 *:* LISTEN 3149/famd
    tcp 0 0 localhost.localdo:spamd *:* LISTEN 1979/spamd.pid
    tcp 0 0 *:sunrpc *:* LISTEN 1602/portmap
    tcp 0 0 *:ftp *:* LISTEN 3086/pure-ftpd (SER
    tcp 0 0 hosting.dateos.d:domain *:* LISTEN 2893/mydns
    tcp 0 0 localhost.locald:domain *:* LISTEN 2893/mydns
    tcp 0 0 *:ssh *:* LISTEN 1821/sshd
    tcp 0 0 *:smtp *:* LISTEN 32265/master
    tcp 0 0 *:36155 *:* LISTEN 1615/rpc.statd
    tcp 0 300 hosting.dateos.dk:ssh 0x5739a01a.cpe.ge:51793 ESTABLISHED 4010/3
    tcp 0 0 hosting.dateos.dk:ssh 0x5739a01a.cpe.ge:51756 ESTABLISHED 20088/1
    tcp 0 0 localhost.localdo:48486 localhost.locald:sunrpc TIME_WAIT -
    tcp 0 0 localhost.localdo:35462 localhost.localdoma:781 TIME_WAIT -
    tcp 0 0 localhost.localdo:43896 localhost.locald:sunrpc TIME_WAIT -
    tcp 0 0 hosting.dateos.dk:ssh 0x5739a01a.cpe.ge:51776 ESTABLISHED 20304/2
    tcp 0 0 localhost.localdo:43769 localhost.localdo:imap2 TIME_WAIT -
    tcp 0 0 hosting.dateos.dk:ssh 0x5739a01a.cpe.ge:51089 ESTABLISHED 3322/0
    tcp 0 0 localhost.localdo:35464 localhost.localdoma:781 TIME_WAIT -
    tcp6 0 0 [::]:imaps [::]:* LISTEN 2856/couriertcpd
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 2880/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 2865/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 2840/couriertcpd
    tcp6 0 0 [::]:http-alt [::]:* LISTEN 3208/apache2
    tcp6 0 0 [::]:www [::]:* LISTEN 3208/apache2
    tcp6 0 0 [::]:ftp [::]:* LISTEN 3086/pure-ftpd (SER
    tcp6 0 0 localhost:domain [::]:* LISTEN 2893/mydns
    tcp6 0 0 [::]:ssh [::]:* LISTEN 1821/sshd
    tcp6 0 0 [::]:https [::]:* LISTEN 3208/apache2
    tcp6 0 0 hosting.dateos.dk:imap2 0x5739a01a.cpe.ge:51786 ESTABLISHED 4001/imapd
    tcp6 0 0 hosting.dateos.dk:www 0x5739a01a.cpe.ge:51792 FIN_WAIT2 -
    tcp6 0 0 hosting.dateos.dk:imap2 0x5739a01a.cpe.ge:51785 ESTABLISHED 4000/imapd

    3. in admin under show system log ill keep getting

    Jun 3 22:55:01 hosting pure-ftpd: (?@localhost.localdomain) [INFO] New connection from localhost.localdomain
    Jun 3 22:55:01 hosting pure-ftpd: (?@localhost.localdomain) [INFO] Logout.
    Jun 3 23:00:01 hosting pure-ftpd: (?@localhost.localdomain) [INFO] New connection from localhost.localdomain
    Jun 3 23:00:01 hosting pure-ftpd: (?@localhost.localdomain) [INFO] Logout.

    every 5 min is this normal ?


    4. in admin under show ISPC cron log

    Error: configuration file /etc/getmail/*.conf does not exist

    all full of this error, anything to do about this ?


    5. the ip address should it be the local ip when behind a router or should it be the static ip from the ISP ill be using ?


    sorry about all those questions but are failing to get the spot on answers out of all the other usefull posts in here about problems like mine.

    really hope some one can give the right answers for me.

    Thanks again in advance for all the help.
     
  2. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is 83.94.206.208 the correct ip address? This is set in the DNS for the domain hosting.dateos.dk
    So if this is not the correct ip address you cannot access the server through this domain.


    What domain are the mail addresses? Are they xxxx@dateos.dk or xxx@hosting.dateos.dk? In the latter case there is no MX record for that domain set.
    Have you set up the domain(s) correctly in ispconfig?


    Yes it is ;)


    This is default because there are no conf files in etc/getmail if you have not configured any getmail accounts. I would say it is a bug, but with no influence on security or functionality.


    If you are behind a router and your server does NOT have the ip address of your isp assigned, you cannot assign the ip address to ispconfig as this would lead to lots of problems in my opinion.
     
  3. clemens

    clemens New Member

    Thanks for the replys :)

    yes that the right ip for the gateway im on, by any chance that i'm missing a file to edit for change of gateway?

    the mail are on the @dateos.dk and @newzsteam.net domain not the hosting.dateos.dk as this only beeing used for ispconfig.
    set up the domain in ispconfig, not sure about what need to be done, i have made a mail domain dateos.dk and under that made the account if anything else needed plz explain.


    getmail account ? is this needed or ? if needed for the mails to work plz point me in the right direction.

    and thanks again...
     
  4. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Ok, it seams that Port 25 is not open or blocked.
    Please make sure that your mailserver (e.g. postfix) is running and that your firewall does not block port 25.
    Port 110 works so that's the reason why pop3 login is ok.

    You only need this if you want to let ispconfig fetch mails from a foreign pop3 account.
     
  5. clemens

    clemens New Member

    Nice, ill just got off the phone with my isp, they were blocking port 25 so sometime tonight mail should be okay, thanks about this issue...

    Then i only have the one problem with not abel to use hosting.dateos.dk:8080 as getting to the admin part, could anyone point me in the right direction on where im missing a change :confused:

    hosting.dateos.dk shows it works and can go to the local ip them im in admin.

    webs are also working

    Thanks again :)
     
  6. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Have a look in the apache vhost file. Maybe the Vhost is set to the local ip and not to the public one.
     
  7. clemens

    clemens New Member

    im not sure witch vhost file you mean but the only one i can find containing :8080 are in /etc/apache2/sites-available/ispconfig.vhost

    for me it seems like it should listen ?
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Post the output of:

    netsat -tap | grep apache

    and

    iptables -L
     
  9. clemens

    clemens New Member

    thanks for the reply, here are the output.

    netstat -tap | grep apache


    iptables -L

     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Looks fine, so ISPConfig should be accessible. Please ask your ISP if they block port 8080.
     

Share This Page