Magento on ISPConfig - php.ini

Discussion in 'Installation/Configuration' started by chrno2004, Jun 19, 2013.

  1. chrno2004

    chrno2004 New Member

    I have configured the server per the install guide:
    The Perfect Server - Debian Wheezy (Apache2, BIND, Dovecot, ISPConfig 3)

    Code:
    Description:    Debian GNU/Linux 7.1 (wheezy)
    Release:        7.1
    Codename:       wheezy
    ISPConfig:      3.0.5.2
    Webserver:      Apache2
    PHP:            suphp
    

    I have created a new site for Magento and the installation guide recommends the following settings:


    Code:
    ; adjust memory limit
    memory_limit = 64M
    max_execution_time = 18000
    
    ; disable magic quotes for php request vars
    magic_quotes_gpc = off
    
    ; disable automatic session start
    ; before autoload was initialized
    flag session.auto_start = off
    
    ; enable resulting html compression
    zlib.output_compression = on
    
    ; disable user agent verification to not break multiple image upload
    suhosin.session.cryptua = off
    
    ; turn off compatibility with PHP4 when dealing with objects
       
    zend.ze1_compatibility_mode = off
    
    ; PHP for some reason ignores this setting in system php.ini 
    ; and disables mcrypt if this line is missing in local php.ini
    extension=mcrypt.so
    
    open_basedir=none
    

    Questions:
    1 . How do I adjust the php.ini for just for this website to reflect the above configuration? Preferably the ISPconfig way so any future changes will stick ... I have attempted to update /var/www/conf/web1/php.ini but it doesn't seems to take effect (checked via phpinfo ) eventhough I have reloaded apache ( /etc/init.d/apache2 reload )

    2. Also is suphp the best option for Magento?


    Any assistance will be greatly appreciated!

    Many thanks!

    chrno
     

Share This Page