MAGENTO & ISPConfig

Discussion in 'Installation/Configuration' started by vaio1, Sep 21, 2008.

  1. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi guys,

    I need some help to configure the server that uses ISPConfig. I would like to use Magento eCommerce Software but the .htaccess stop the execution with these errors:

    Code:
    [Sun Sep 21 10:26:11 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: php_flag not allowed here
    [Sun Sep 21 10:26:11 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: php_flag not allowed here
    [Sun Sep 21 10:26:38 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: php_flag not allowed here
    [Sun Sep 21 10:26:38 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: php_flag not allowed here
    [Sun Sep 21 10:27:10 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: SSLOptions not allowed here
    [Sun Sep 21 10:27:10 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: SSLOptions not allowed here
    [Sun Sep 21 10:27:33 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: Options not allowed here
    [Sun Sep 21 10:27:33 2008] [alert] [client 11.23.222.211] /var/www/web7/web/_testing/.htaccess: Options not allowed here
    [Sun Sep 21 10:28:03 2008] [error] [client 11.23.222.211] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: http://magento.mywebsite.com/
    
    this is the .htaccess furnished by the Varien company:
    Code:
    ############################################
    ## uncomment these lines for CGI mode
    ## make sure to specify the correct cgi php binary file name
    ## it might be /cgi-bin/php-cgi
    
    #    Action php5-cgi /cgi-bin/php5-cgi
    #    AddHandler php5-cgi .php
    
    ############################################
    ## GoDaddy specific options
    
    #   Options -MultiViews
    
    ## you might also need to add this line to php.ini
    ##     cgi.fix_pathinfo = 1
    ## if it still doesn't work, rename php.ini to php5.ini
    
    ############################################
    ## this line is specific for 1and1 hosting
    
        #AddType x-mapp-php5 .php
        #AddHandler x-mapp-php5 .php
    
    ############################################
    ## default index file
    
        DirectoryIndex index.php
    
    <IfModule mod_php5.c>
    
    ############################################
    ## adjust memory limit
    
    #    php_value memory_limit 64M
        php_value memory_limit 128M
        php_value max_execution_time 18000
    
    ############################################
    ## disable magic quotes for php request vars
    
        php_flag magic_quotes_gpc off
    
    ############################################
    ## disable automatic session start
    ## before autoload was initialized
    
        php_flag session.auto_start off
    
    ############################################
    ## enable resulting html compression
    
        #php_flag zlib.output_compression on
    
    ###########################################
    # disable user agent verification to not break multiple image upload
    
        php_flag suhosin.session.cryptua off
        
    ###########################################
    # turn off compatibility with PHP4 when dealing with objects
        
        php_flag zend.ze1_compatibility_mode Off
    
    </IfModule>
    
    <IfModule mod_security.c>
    ###########################################
    # disable POST processing to not break multiple image upload
    
        SecFilterEngine Off
        SecFilterScanPOST Off
    </IfModule>
    
    <IfModule mod_deflate.c>
    
    ############################################
    ## enable apache served files compression
    ## http://developer.yahoo.com/performance/rules.html#gzip
    
        # Insert filter
        #SetOutputFilter DEFLATE
    
        # Netscape 4.x has some problems...
        #BrowserMatch ^Mozilla/4 gzip-only-text/html
    
        # Netscape 4.06-4.08 have some more problems
        #BrowserMatch ^Mozilla/4\.0[678] no-gzip
    
        # MSIE masquerades as Netscape, but it is fine
        #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
        # Don't compress images
        #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary
    
        # Make sure proxies don't deliver the wrong content
        #Header append Vary User-Agent env=!dont-vary
    
    </IfModule>
    
    <IfModule mod_ssl.c>
    
    ############################################
    ## make HTTPS env vars available for CGI mode
    
        SSLOptions StdEnvVars
    
    </IfModule>
    
    <IfModule mod_rewrite.c>
    
    ############################################
    ## enable rewrites
    
        Options +FollowSymLinks
        RewriteEngine on
    
    ############################################
    ## you can put here your magento root folder
    ## path relative to web root
    
        #RewriteBase /magento/
    
    ############################################
    ## workaround for HTTP authorization
    ## in CGI environment
    
        RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
    ############################################
    ## always send 404 on missing files in these folders
    
        RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
    
    ############################################
    ## never rewrite for existing files, directories and links
    
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-l
    
    ############################################
    ## rewrite everything else to index.php
    
        RewriteRule .* index.php [L]
    
    </IfModule>
    
    
    ############################################
    ## Prevent character encoding issues from server overrides
    ## If you still have problems, use the second line instead
    
        AddDefaultCharset Off
        #AddDefaultCharset UTF-8
    
    <IfModule mod_expires.c>
    
    ############################################
    ## Add default Expires header
    ## http://developer.yahoo.com/performance/rules.html#expires
    
        ExpiresDefault "access plus 1 year"
    
    </IfModule>
    
    ############################################
    ## By default allow all access
    
        Order allow,deny
        Allow from all
    
    ############################################
    ## If running in cluster environment, uncomment this
    ## http://developer.yahoo.com/performance/rules.html#etags
    
        #FileETag none
    
    
    Can we create a version of this .htaccess for ISPConfig hosting?

    Regards
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Just copy the content of the .htaccess file into the apache directives field of the website or allow the overriding of the functions mentioned in the error log in apache2.conf.
     
  3. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

  4. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    The Directory directives doesn't work.
    This is a strange situation.
     
  5. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please try

    Code:
    <Directory /var/www/web7/web/>
            AllowOverride All
    </Directory>
    in the Apache Directives field of web7.
     
  6. hahni

    hahni New Member

    Hello Falco,

    the Directory Directive doesn't work!
    I have installed Magento by extracting the zip-package. I have set the directive but i got this error:

    ---
    Fatal error: Uncaught exception 'Exception' with message 'Warning: file_exists() [<a href='function.file-exists'>function.file-exists</a>]: open_basedir restriction in effect. File(/tmp/magento/var) is not within the allowed path(s): (/var/www/web999/) in /var/www/web999/web/app/code/core/Mage/Core/Model/Config.php on line 745' in /var/www/web999/web/app/code/core/Mage/Core/functions.php:246 Stack trace: #0 [internal function]: mageCoreErrorHandler(2, 'file_exists() [...', '/var/www/web999/...', 745, Array) #1 /var/www/web999/web/app/code/core/Mage/Core/Model/Config.php(745): file_exists('/tmp/magento/va...') #2 /var/www/web999/web/app/code/core/Mage/Core/Model/Config/Options.php(101): Mage_Core_Model_Config->createDirIfNotExists('/tmp/magento/va...') #3 /var/www/web999/web/app/code/core/Mage/Core/Model/Config/Options.php(39): Mage_Core_Model_Config_Options->getVarDir() #4 /var/www/web999/web/app/Mage.php(205): Mage_Core_Model_Config_Options->getDir('var') #5 /var/www/web999/web/app/Mage.php(641): Mage::getBaseDir('var') #6 /var/ in /var/www/web999/web/app/code/core/Mage/Core/functions.php on line 246
    ---

    Best regards

    Hahni
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please switch off PHP Safe Mode.
     
  8. hahni

    hahni New Member

    Hello Falko,

    Thank you very much for your good tip. I can use the original .htaccess and there is no need for other changes.

    Best regards

    Hahni
     

Share This Page