Mac Server - Postfix Issue on certain ISP or Network

Discussion in 'HOWTO-Related Questions' started by rjbathgate, Jul 10, 2012.

  1. rjbathgate

    rjbathgate New Member


    I have Mac Server and MAMP running as my local server, and have set up Postfix in MAMP to enable outgoing mail.

    I have the smart host set as

    When I connect the machine to the internet using my mobile phone network (vodafone), all works perfectly.

    However, when I connect the machine to the internet with my normal ISP, through my LAN, postfix returns the error:

    Host or Domain name not found. Name service error for type=MX Host not found, try again

    I have tried it changing the smarthost to the ISP's, same issue.

    Using the command dig (or indeed dig it ONLY returns A names, no MX. A 'dig MX' (or dig MX) returns a timeout.

    My LAN is a router behind a modem, nothing more than that.

    So, where should I start?

    The fact it works on my vodafone ISP suggests it's either an issue with my normal ISP blocking something? or my local network set up?

    Any suggestions, most appreciated.

  2. falko

    falko Super Moderator ISPConfig Developer

    I think you should try other nameservers, e.g. the ones from Google:
  3. rjbathgate

    rjbathgate New Member

    Thanks for the reply.

    My /etc/resolv.conf looks like this:


    however the same problem exists - mail send fails with same error.

    However now dig MX is returning MX records instead of timing out...

    But mailq returns "name service error for type=MX: host not found, try again"

    If I change domain of outgoing in MAMP Postfix to, same error.

    So we've got somewhere in that it can return dig MX now...

    Thanks again in advance.


Share This Page