LVS-NAT: Problems with PHP-SOAP server behind ldirectord

Discussion in 'HOWTO-Related Questions' started by andeas-2008, Feb 5, 2008.

  1. andeas-2008

    andeas-2008 New Member

    Hi,

    I am running LVS with NAT. Everything is working fine, no problem with http and https from browsers or via wget.

    The only problem I have is with our soap-server (PHP 5.2.5) running on a real server. SOAP requests (no matter if http or https) alsways get a timeout. With tcpdump i can watch them reaching the ldirector and after that the real server (the real server are in a different subnet than the virtual IPs on the ldirector). The real server are sending replies, but they seem to stuck. As said, the problem only occurs with SOAP (I guess, PHP soap uses an own socket communication). This special environment makes it difficult to search for solutions. Maybe a bug in PHP.

    Does anybody have experience with this?

    I tried running LVS without NAT (direct LVS) and this works fine with PHP SOAP. It seems to be a problem concerning NAT and SOAP.


    Andreas
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to increase the timeout of your PHP scripts (set_time_limit())? Maybe the SOAP connection is a little bit slow.
     
  3. wcarty

    wcarty New Member

    Do you have lvs persistence configured along with iptables firewall marks
     

Share This Page