Lots of different problems

Discussion in 'Server Operation' started by Trunkles, Dec 28, 2016.

  1. Trunkles

    Trunkles Member

    Hi folks. I'm tearing my hair out here. I migrrated to a new server using the ISPConfig3 migration tool and following the Perfect Server 16.04 instructions. Everything appears to be ok but...
    • Basic websites work ok , wordpress based ones just give a blank page.
    • http://webmail.<domainname> gives the default apache2 webpage rather than the roundcube login page.
    • E-mails going in or leaving from my server bounce with a '530 5.7.0 Must issue a STARTTLS command first (in reply to end of DATA command)'
    And I don't know what to do. I've checked everything I can think of, including smiling at the server and saying please, but to no avail. The thing is that I'm not a commercial operation, my clients are local charitable organisations or friends so I don't have any money to pay for help with.

    Please... HELP!
    Simon.
     
  2. Trunkles

    Trunkles Member

  3. Trunkles

    Trunkles Member

    I was under the impression you could set up autto-repsond messages, such as 'Out of Office' in roundcube but I can't find that functionality.
     
  4. Trunkles

    Trunkles Member

    A run of postfix check gave me this. I wonder what is actually relevant.

    root@laphroaig:/etc/postfix# postfix check
    postfix: Postfix is running with backwards-compatible default settings
    postfix: See http://www.postfix.org/COMPATIBILITY_README.html for details
    postfix: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./libpostfix-util.so.1
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./libpostfix-tls.so.1
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./sbin/lmtp
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./libpostfix-global.so.1
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./libpostfix-master.so.1
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/./libpostfix-dns.so.1
    postfix/postfix-script: warning: group or other writable: /usr/lib/postfix/sbin/./lmtp

    I've also noticed that postfix's restrictions on sender addresses maps to 'FILTER amavis:[127.0.0.1]:10026' and 'FILTER amavis:[127.0.0.1]:10024' Whic I suspect is wrong.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the error.log of the website. A blank page is often a 500 error and this ca be caused if code of the websites is not compatible with the new php 7 version on Ubuntu 16.04.

    Webmail on the perfect server can be reached under domain.tld/webmail or domain.tld/roundcube depending on the installed webmail application and not webmail.domain.tld. This was the case in all perfect servers etups that we published. If you used a different approach to reach webmail, then you will have to add that to the new server as well as such a config is not part of ispconfig and therefore does not get migrated automatically.

    Most likely a typo in the postfix master.cf file. Check that you removed the # in front of the smtps and submission lines as shown in the perfect server guide.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no such functionality in roundcube itself, but there is a ispconfig roundcube addon which provides such functions.
     
  7. Trunkles

    Trunkles Member

    I tried accessing one of the wordpress sites and then checked /var/apache2/error.log. No entries in it that are related to that attempt to access.

    The # on the front are now removed and email is now coming in but not leaving. I tried sending an email and this is the mail.log bit that's related to it.
    127.0.0.1]:10026; from=<simon@drsimon.co.nz> to=<admor@juno.com> proto=ESMTP helo=<[192.168.1.5]>
    Dec 28 22:46:35 laphroaig postfix/smtpd[14041]: C1BCD2001A96: client=router[192.168.1.254], sasl_method=PLAIN, sasl_username=simon@drsimon.co.nz
    Dec 28 22:46:35 laphroaig postfix/cleanup[14989]: C1BCD2001A96: message-id=<6bee476d-59d4-b7a5-0d9a-be85950d7cdd@drsimon.co.nz>
    Dec 28 22:46:35 laphroaig postfix/qmgr[11305]: C1BCD2001A96: from=<simon@drsimon.co.nz>, size=100662, nrcpt=1 (queue active)
    Dec 28 22:46:35 laphroaig postfix/smtpd[14041]: disconnect from router[192.168.1.254] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
    Dec 28 22:46:37 laphroaig amavis[13433]: (13433-03) (!)connect to 127.0.0.1:* failed, attempt #1: Can't connect to socket 127.0.0.1:* using module IO::Socket::IP: Connection refused
    Dec 28 22:46:37 laphroaig amavis[13433]: (13433-03) (!)8FmB7KSVvba4 FWD from <simon@drsimon.co.nz> -> <admor@juno.com>, 451 4.5.0 From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=13433-03
    Dec 28 22:46:37 laphroaig amavis[13433]: (13433-03) Blocked MTA-BLOCKED {TempFailedOutbound}, ORIGINATING LOCAL [192.168.1.254]:61858 <simon@drsimon.co.nz> -> <admor@juno.com>, Queue-ID: C1BCD2001A96, Message-ID: <6bee476d-59d4-b7a5-0d9a-be85950d7cdd@drsimon.co.nz>, mail_id: 8FmB7KSVvba4, Hits: 0.806, size: 100662, 1457 ms
    Dec 28 22:46:37 laphroaig postfix/smtp[14990]: C1BCD2001A96: to=<admor@juno.com>, relay=127.0.0.1[127.0.0.1]:10026, delay=1.6, delays=0.1/0.01/0/1.5, dsn=4.5.0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 id=13433-03 - Temporary MTA failure on relaying, From MTA() during fwd-connect (All attempts (1) failed connecting to smtp:127.0.0.1:*): id=13433-03 (in reply to end of DATA command))
     
  8. Trunkles

    Trunkles Member

    I'm wondering if the 'no send' is related to the double mapping I mentioned for amavis.
     
  9. Trunkles

    Trunkles Member

    Thank you Till, you're probably right about the wordpress code, I'll look for an update for it.
     
  10. Trunkles

    Trunkles Member

    Getting the latest version of wordpress now. :)
     
  11. Trunkles

    Trunkles Member

    E-mail now seems to be working. HOORAY! Thank you Till. :)
    Wordpress is still giving me grief though. I'll get there in the end.
     

Share This Page