Lot of mail isn't coming in and spamassassin hangs

Discussion in 'General' started by jorizzzz, Feb 1, 2008.

  1. jorizzzz

    jorizzzz New Member

    Hi Guys (and Girls if there are any here),

    Lately i've got another problem with one of my servers. Alot of emails won't reach the users on my server and get returned to the senders without a logical explanation...

    I can't seem to find anything useful in the log files and i already checked my ip address for blacklisting.

    I thought to have found the problem of this, i frequently saw a spamassassin process hanging in my process list. The first time i saw it, it hang on the mailbox of my colleague. I turned spamfilter off on his account, but today i saw it on another account of one of my customers. The process was running for more than 8 hours on one mailbox!

    The funny thing is, after disabeling spamfilter on my colleague's account, some mails still didn't find their way through my server..

    So, does anybody know how i can fix Spamassassin? Maybe a seperate install instead of using the ISPConfig install?

    I'm currently running on the latest stable version of ISPConfig.

    Thanks in advance!
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
  3. jorizzzz

    jorizzzz New Member

    It's blank, no output...
  4. falko

    falko Super Moderator ISPConfig Developer

    This means that the SpamAssassin configuration is ok. Not sure why it's hanging then... :(
  5. jorizzzz

    jorizzzz New Member

    Could you tell me how i can disable spamassassin completely for the time being? I want to investigate further but without my clients losing mail..
  6. falko

    falko Super Moderator ISPConfig Developer

    You must disable spam scanning for each single account in ISPConfig...

Share This Page