Losts of upgrades, lots of problems

Discussion in 'Installation/Configuration' started by webno, Feb 2, 2008.

  1. webno

    webno New Member

    On my server I upgraded the following software:

    ispconfig:
    2.9 -> 2.19

    debain dist-upgrade:
    sarge -> etch

    PHP:
    PHP Version 4.4.7-0.dotdeb.0 -> PHP Version 5.2.0-8+etch10

    mysql: !!
    mysqlserver: 5.0.32-1.dotdeb.1 -> 5.0.32-7etch4
    mysqlclient: 5.0.38.1-dotdeb.0 -> 5.0.32-7etch3~bpo31+1

    I was pleased that the upgrade went smooth until problems started appearing.

    I noticed that for Drupal sites I had to change the connection string from mysql:[email protected]:/db

    to

    mysqli:[email protected]/db

    Using mysql instead of mysqli would kick me out of my login session.

    If I try to do the same with moodle sites the site functions correctly, only the content is garbled when it comes to special characters.


    Problem1:

    When I try to log on to web sites on which I previously logged on the username field normally contains my name but now shows up garbled. See attachement loginsform2.png

    Problem2:
    Most of the special characters on website show up correctly but a few sites contain garbled information

    Problem3:
    On some sites users get kicked out of their login session when clicking a link to another resource within the webapplication.

    I compared the phpinfo output of both environments carefully (attached) especially the session section, but could not find any significant difference.

    Does anyone have an idea what is going wrong, or how to further get insight into this problem?

    Bart.
     

    Attached Files:

  2. falko

    falko Super Moderator ISPConfig Developer

  3. webno

    webno New Member

    Data in the database was UTF8 but the tables where set on latin1 and there was no default charset set in httpd.conf.

    Thanks.
     

Share This Page