Lost the ISPConfig login page

Discussion in 'Installation/Configuration' started by jopa123, Sep 16, 2010.

  1. jopa123

    jopa123 New Member

    Okay. I went back to the drawing board, formatted the drive, and reinstalled per the "The Perfect Server - Ubuntu 9.04 [ISPConfig 3]" tutorial. All seemed to go well.

    I am behind a router and I WAS able get to the ISPconfig login internally by going to 192.168.1.26:8080. Externally I was not able to.

    When I would enter the external ipaddress in firefox [68.113.170.x:8080, the dns is not yet registered, therefore I cannot enter server1.example.com:8080), I got an error message that said "you do not have permission to access / on this server". Yes, "/"

    I did some research and began to play with the router port forwarding settings and the port settings in ISPconfig. I tried 8081, 8088, and a few more, with no luck. Now I cannot reach the ISPConfig login screen, externally or internally.

    A little more research showed that my router (Lynksys) has a default Remote Management Port of 8080. I changed this to another port.

    I tried to change the ISPConfig port following the instructions here:

    http://www.howtoforge.com/forums/archive/index.php/t-157.html

    But none of the commands seem to work for me.

    For instance:

    "c/init.d/ispconfig_server stop" and "/etc/rc.d/init.d/ispconfig_server stop "

    both return

    bash: /etc/init.d/ispconfig_server: No such file or directory (or similar)


    $go_info[server1.rockwallretail.com][68.113.170.x]

    returns

    bash: [server1.example.com][68.113.170.x]: command not found

    (With internal or external ip address, with or without brackets)

    It almost seems that ISPConfig got uninstalled, but there are plenty of ISPConfig files on the machine, mostly in /usr/local and /var/lib/mysql

    This project was intended to help me learn some Linux. I guess I'm doing it the hard way, by screwing up. But then, that's how I learned Windoze.

    Once again any help is greatly appreciated.
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The tutorial that you used to change the port is for a different software. ISPConfig 2 is not the same software then ispconfig 3. Please undo all changes you made.

    To change the port of ispconfig 3, just download the ispconfig 3 tar.gz again, start the update.php script and select the new port.
     
  3. jopa123

    jopa123 New Member

    So simple, yet so correct.

    Thanks, Till.

    I didn't know this could be done this way. Everything looks perfect now, internally and externally.

    You guys rock! Keep up the good work.
     

Share This Page