Lost permissions after upgrade

Discussion in 'Installation/Configuration' started by fbessone, Oct 29, 2012.

  1. fbessone

    fbessone New Member


    i upgraded to last ispconfig version and since that a normal users instead of seeing only his websites can see all, how can i reset permissions so that each client sees only belonged websites ?

    Additionally, i can no longer access ispconfig interface/phpmyadmin through https but only http.

    Does anybody has an idea about it?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the affected user under System > CP users and ensure that the user type is "user" and not "admin".
  3. fbessone

    fbessone New Member

    Thank you !

    Thanks Till,
    it was indeed changed to ADMIN. Reverted to user and now he sees only his websites.

    For :8080 ispconfig panel, if i try to open it with https it reports back
    Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error

    How can i fix it ?
    Thanks again
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The panel is only available as http or https but not http and https at the same time. So if it opens fine with http, then ssl has not been enabled for the panel during installation or update.
  5. fbessone

    fbessone New Member


    Ok, i understand. Maybe i havent selected the right option during upgrade.
    Is there any chance to re-run the upgrade or to enable ssl and disable http ?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the ispconfig tar.gz, unpack it and run the update.php script which is in the install folder. During update, choose to recreate the sl cert as it does not seem to exist on your server or it was stored in the wrong location so that the updater could not find it.

Share This Page