Lost access to webs and web admin ("ERR_CONNECTION_REFUSED")

Discussion in 'General' started by amp, Mar 26, 2019.

  1. amp

    amp New Member

    Hi there, thank you in advance to everyone who could help in this:
    Websites hosted in our ISPConfig are not reachables, we get this error in the browser: "ERR_CONNECTION_REFUSED"
    And what is worst: we cannot even access the web admin via mysubdomain.mydomain.com:8080 , we get the same "ERR_CONNECTION_REFUSED"

    The last thing we were doing in the web admin was deleting a certificate via the web admin, as shown below, in this path: sites - (select the website) - select the SSL tab - SSL action = delete
    upload_2019-3-26_11-28-1.png

    We have already tried rebooting the server without sucess.

    In the other hand, Email is working properly

    Any help will be appreciated.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this an apache or nginx web server and which Linux distribution do you use?
     
  3. amp

    amp New Member

    Is apache web server, and Debian 8
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the symlink with the name of the website were you removed the ssl cert in /etc/apache2/sites-enabled/ folder and then restart apache with:

    service apache2 restart
     
    amp likes this.
  5. amp

    amp New Member

    Ok, we have deleted the symlinks named as: 100-mydomain.com.vhost, 100-otherdomain.com.vhost ... and some other named 100-otherdomain.com.vhost_OLD (the ones which we deleted the SSL certificate via the webadmin)

    We have NOT deleted other symlinks existing in the same folder, 000-apps.vhost 000-default.conf 000-ispconfig.conf 000-ispconfig.vhost 900-yetanotherdomain.com.vhost backup_100-otherdomain.com.vhost backup_vhost default-ssl.conf otherdomain.com.vhost_NEW
    Then we have done:
    [email protected]:/etc/apache2/sites-enabled# /etc/init.d/apache2 restart

    [....] Restarting apache2 (via systemctl): apache2.serviceJob for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
    failed!

    So then we have moreover done:
    [email protected]:/etc/apache2/sites-enabled# systemctl status apache2.service

    * apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2)
    Drop-In: /lib/systemd/system/apache2.service.d
    `-forking.conf
    Active: failed (Result: exit-code) since mar 2019-03-26 11:45:48 CET; 16s ago
    Process: 18996 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
    Process: 21298 ExecStart=/etc/init.d/apache2 start (code=exited, status=1/FAILURE)

    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: Output of config test was:
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: [Tue Mar 26 11:45:48.778595 2019] [alias:warn] [pid 21307] AH00671: The Alias directive in /etc/apache2/conf-enabled/squirrelmail....rlier Alias.
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: AH00526: Syntax error on line 64 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: SSLCertificateKeyFile: file '/usr/local/ispconfig/interface/ssl/ispserver.key' does not exist or is empty
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: Action 'configtest' failed.
    mar 26 11:45:48 mysubdomain.mydomain.com apache2[21298]: The Apache error log may have more information.
    mar 26 11:45:48 mysubdomain.mydomain.com systemd[1]: apache2.service: control process exited, code=exited status=1
    mar 26 11:45:48 mysubdomain.mydomain.com systemd[1]: Failed to start LSB: Apache2 web server.
    mar 26 11:45:48 mysubdomain.mydomain.com systemd[1]: Unit apache2.service entered failed state.
    Hint: Some lines were ellipsized, use -l to show in full.
    [email protected]:/etc/apache2/sites-enabled#
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You did not mention that you deleted the ssl certs via webmin, I thought you used the proper way by doing this in ISPConfig. Using Webmin must crash the server of course as Webmin will not remove it from apache vhosts properly, so apache service must be dead after such an action.

    Beside that, ISPConfig does not create files with _NEW and _OLD there, so someone must have heavily edited and copied vhots files manually on your server if you had such files and this must bring down apache too as you have multiple copies of the same vhost then.

    Seems as if you deleted the /usr/local/ispconfig/interface/ssl/ispserver.key file as well, this cannot be deleted trough ispconfig, so it must have been removed manually. To fix that, run an ispconfig update and choose to create a new ssl cert for ispconfig during update.
     
  7. amp

    amp New Member

    Just to clarify: we do not use "WEBMIN". Maybe that has been misunderstood when we said "Web Admin". We wanted to mean we deleted the certificates in the ISPConfig option for do that. As said before, we did it in this path: sites - (select the website) - select the SSL tab - SSL action = delete ).

    The files _NEW and _OLD you are right, they were created by someone of us. We have now taken them away from that folder.

    So as you told us in the last message, we have done an ispconfig update, and chose to create a new ssl cert for ispconfig during update.
    After that, we get this:

    [email protected]:/# /etc/init.d/apache2 restart
    [ ok ] Restarting apache2 (via systemctl): apache2.service.


    [email protected]:/# systemctl status apache2.service
    * apache2.service - LSB: Apache2 web server
    Loaded: loaded (/etc/init.d/apache2)
    Drop-In: /lib/systemd/system/apache2.service.d
    `-forking.conf
    Active: inactive (dead) since mar 2019-03-26 12:37:45 CET; 2s ago
    Process: 4620 ExecStop=/etc/init.d/apache2 stop (code=exited, status=0/SUCCESS)
    Process: 4602 ExecStart=/etc/init.d/apache2 start (code=exited, status=0/SUCCESS)

    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: Starting web server: apache2[Tue Mar 26 12:37:44.970181 2019] [alias:warn] [pid 4616] AH00671: The Alias directive in /etc/apache2/...rlier Alias.
    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:8080
    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: Action 'start' failed.
    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: The Apache error log may have more information.
    mar 26 12:37:44 hosting.futurasp.es apache2[4602]: .
    mar 26 12:37:45 hosting.futurasp.es apache2[4620]: Stopping web server: apache2.
    mar 26 12:37:45 hosting.futurasp.es systemd[1]: Started LSB: Apache2 web server.
    Hint: Some lines were ellipsized, use -l to show in full.

    ...thank you in advance for all your help
     
  8. amp

    amp New Member

    Finally we managed to get ISPConfig and Apache working again, restorings some folders we had in our backup.

    Thank you for your help!
     

Share This Page