Losing access to the server on enabling UFW in ISPCONFIG

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Nov 6, 2018.

  1. pawan

    pawan Member HowtoForge Supporter

    I didn't experienced this issue, can't figure out why this is happening.
    I checked the UFW status in terminal, it shows
    ufw inactive.
    then I checked in ISPCONFIG, it was showing as active, so I unchecked the enable status and saved.
    then checked it again and saved.
    Immediately all my connection to the server is lost.
    what could be the reason for that?
    I had it added all the ports for the firewall.
    I am attaching a snapshot, just before I enabled it.
    upload_2018-11-7_2-4-1.png
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This might happen when a wrong firewall type is selected or the firewall type got changed after you added the firewall record.

    Which firewall type is listed as active under system > server config?
     
  3. pawan

    pawan Member HowtoForge Supporter

    Yes I think that is possible as I haven't saved this screen and the records showing is coming from the backup from old server.
    my /etc/netplan/01-netcfg.yaml file contents are like this
    network:
    version: 2
    renderer: networkd
    ethernets:
    eno1:
    dhcp4: no
    dhcp6: no
    addresses: [69.197.195.186/29]
    gateway4: 69.197.195.185
    nameservers:
    addresses: [192.187.107.16, 69.30.209.16]

    and under system > server config the page looks like this
    upload_2018-11-7_15-37-59.png

    so should I update this page matching the netplan?
    what value will go in netmask. is 255.255.255.0 is fine?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, that's ok as these settings are not used. I was talking just about the ufw setting. But basically, you explained the reason for the issue in your last post. when these settings come from another server then the firewall record comes from that other server as well, so it exists just in ispconfig and not in ufw when you copied the ispconfig database, so ufw was basically off and unconfigured and by starting it manually, you blocked all ports. Delete the record under firewall and then add it again, this will setup ufw with the rules.
     
    pawan likes this.

Share This Page