Loop detected! We were referred back to

Discussion in 'ISPConfig 3 Priority Support' started by xrstokes, Apr 24, 2019.

  1. xrstokes

    xrstokes Member

    Hi guys, Sorry i need to post. Been doing this for ages and can usually work it out from the forums but my brain is well and truly busted now.
    I used the migration tool to migrate to another server. old server was debian 8, new server ubuntu 18. also new server is behind nat. I believe being behind the nat is the problem. Users aren't receiving emails from most places. a few get through but most get the error. 4.2.1 Recipient address rejected: Domain not found).. MXTOOLBOX says there is a loop detected and referred back to old servers ip. address. https://www.mailcontrol.com/utility/domain_info.mhtml show the correct records though. Part of the problem may be that I haven't managed to add the external address to an interface of the server. so if I telnet 25 to the record. it trys to telnet the router/gateway. not knowing what its external address is, could be related?

    $TTL 3600
    @ IN SOA ns1.yyy.com.au. admin.yyy.com.au. (
    2019042424 ; serial, todays date + todays serial #
    7200 ; refresh, seconds
    540 ; retry, seconds
    604800 ; expire, seconds
    3600 ) ; minimum, seconds
    mx1 3600 A aaa.aaa.aaa.aaa
    mx2 3600 A bbb.bbb.bbb.bbb
    xxx.com.au. 3600 A ccc.ccc.ccc.ccc
    www 3600 A ccc.ccc.ccc.ccc
    xxx.com.au. 3600 MX 5 mx1.xxx.com.au.
    xxx.com.au. 3600 MX 10 mx2.xxx.com.au.
    xxx.com.au. 3600 NS ns1.yyy.com.au.
    xxx.com.au. 3600 NS ns2.yyy.com.au.
    default._domainkey.xxx.com.au. 3600 TXT "v=DKIM1; t=s; p=MIGfMxxxxxxZo0evTh8i11QIDAQAB"
    xxx.com.au. 3600 TXT "v=spf1 mx a ~all"

    please help.

  2. xrstokes

    xrstokes Member

    More info, there is a second mirror server that has the same config but is not behind nat [mx2] if I change the priority and try to steer the mail through that server I still get the same error. I'm starting to think the only mail that has got through for the last 2 days is from the old server. Yikes!....internal mail works fine. sending works fine. Receiving from outside seems busted. Can telnet to ports fine. Thinking DNS error still. One of my clients uses external DNS server and his mail is getting through the new servers fine.
  3. xrstokes

    xrstokes Member

    Also gmail seems to be working around whatever the problem is. But Hotmail mail is backing up.
    Also I can telnet into the server on 25 and send a simple msg. goes to spam but works.
    Last edited: Apr 24, 2019
  4. xrstokes

    xrstokes Member

    got it. Sorry guys. It was an extra host record at my dns provider creating a loop. A million emails awaiteth. mark as solved
    till likes this.

Share This Page