Loop detected! We were referred back to IP

Discussion in 'Installation/Configuration' started by tjbcham, May 15, 2016.

  1. tjbcham

    tjbcham New Member

    New server with Debian Jessie, installed ISPconfig 3 no problem, however getting errors from MX Toolbox
    Loop detected! We were referred back to ip

    I believe my DNS setting is right for the domain... however using named-checkzone as in other threads
    :~# named-checkzone mydomain.com /etc/bind pri.mydomain.com does not return anything except:

    usage: named-checkzone [-djqvD] [-c class] [-f inputformat] [-F outputformat] [- t directory] [-w directory] [-k (ignore|warn|fail)] [-n (ignore|warn|fail)] [-m (ignore|warn|fail)] [-r (ignore|warn|fail)] [-i (full|full-sibling|local|local-s ibling|none)] [-M (ignore|warn|fail)] [-S (ignore|warn|fail)] [-W (ignore|warn)] [-o filename] zonename filename

    Here is:

    $TTL        3600
    @       IN      SOA     ns1.mydomain.com. myemail.gmail.com. (
                            2016051507       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    mail 3600 A        163.172.32.XXX
    ns1 86400 A        163.172.32.XXX
    ns1.mydomain.com. 86400 A        163.172.32.XXX
    ns2 86400 A        163.172.32.XXX
    ns2.mydomain.com. 86400 A        163.172.32.XXX
    mydomain.com. 3600 A        163.172.32.XXX
    www 3600 A        163.172.32.XXX
    mydomain. 3600      MX    10   mail.mydomain.com.
    mydomain. 3600      NS        ns1.mydomain.com.
    mydomain. 3600      NS        ns2.mydomain.com.
  2. tjbcham

    tjbcham New Member

    Found one issue:
    My /etc/bind/named.conf.options file had:

    listen-on {; };

    I changed it to:

    listen-on { any; };

    And now the name resolves in MX Tool box...

    Did the ISPConfig 3 install set up that file that way, or is it from the server host configuration of Debian Jessie? I have done several ISPconfig install and never had this problem.

Share This Page