Loop detected! We were referred back to error and port 22 ssh Timeout

Discussion in 'Installation/Configuration' started by tbctr, Apr 7, 2015.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Editing the file wont help you as the file is excluded from bind due to errrs, so you have to login to ispconfig and add the records there. Your zone will be fine by just adding 2 a-records, one for ns1 and one for ns2 and do not remove the NS records.
     
  2. tbctr

    tbctr Member

    [​IMG]
    /etc/bind/pri.koyuncuspor.net.err
    Code:
    $TTL        3600
    @       IN      SOA     n1.koyuncuspor.net. mkoyuncu.koyuncuspor.com. (
                            2015042303       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
    
    koyuncuspor.net. 3600 A        176.40.159.139
    mail 3600 A        176.40.159.139
    n1.koyuncuspor.net 86400 A        176.40.159.139
    n2.koyuncuspor.net 86400 A        176.40.159.139
    www 3600 A        176.40.159.139
    koyuncuspor.net. 3600      MX    10   mail.koyuncuspor.net.
    koyuncuspor.net. 3600      NS        n1.koyuncuspor.net.
    koyuncuspor.net. 3600      NS        n2.koyuncuspor.net.
    
    still error :
    Loop detected! We were referred back to '176.40.159.139'
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You have typos in the A recods, the dot at the end of the domain name is missing in the ns1 and ns2 record.
     
  4. tbctr

    tbctr Member

    Code:
    $TTL        3600
    @       IN      SOA     n1.koyuncuspor.net. mkoyuncu.koyuncuspor.com. (
                            2015042303       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
    
    koyuncuspor.net. 3600 A        176.40.159.139
    mail 3600 A        176.40.159.139
    n1.koyuncuspor.net. 86400 A        176.40.159.139
    n2.koyuncuspor.net. 86400 A        176.40.159.139
    www 3600 A        176.40.159.139
    koyuncuspor.net. 3600      MX    10   mail.koyuncuspor.net.
    koyuncuspor.net. 3600      NS        n1.koyuncuspor.net.
    koyuncuspor.net. 3600      NS        n2.koyuncuspor.net.
    
    I fixed it but still the same error :confused::confused::confused:
    http://mxtoolbox.com/SuperTool.aspx?action=mx:koyuncuspor.net&run=toolpage#
    domain ns record deleted new record but again error :mad:o_O:(
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the file has still an .err ending? Doe sthe named-checkzone script tells you now that the zonefile is ok?
     
  6. tbctr

    tbctr Member

    Code:
    [email protected]:/etc/bind# ls
    bind.keys  db.127  db.empty  db.root     named.conf.default-zones  named.conf.options       rndc.key  zones.rfc1918
    db.0       db.255  db.local  named.conf  named.conf.local          pri.koyuncuspor.net.err  slave
    
     
  7. tbctr

    tbctr Member

    Code:
    [email protected]:/etc/bind# named-checkzone koyuncuspor.net /etc/bind/pri.koyuncuspor.net.err
    zone koyuncuspor.net/IN: loaded serial 2015042303
    OK
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    seems as if you edited the file /etc/bind/pri.koyuncuspor.net.err manually instead of doing the changes in ispconfig.
     
  9. tbctr

    tbctr Member

    I made a lot of changes. First ispconfig Add new dns zone with wizard step by step. Loop error then manuel edit pri.koyuncuspor.net.err. But still I could not find a solution :(
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    your zonefile has a correct syntax now, but this does not help you as you manually edited the file instaed of doing it in ispconfig. So login now to ispconfig and do the changes there and wait 60 seconds until the file got written. The file will then be there without .err ending.
     
  11. tbctr

    tbctr Member

    Thank you very much till. Finally resolved problem.:);):cool:
     

Share This Page