Looking to open up a port on my server

Discussion in 'General' started by onastvar, Apr 12, 2013.

  1. onastvar

    onastvar Member

    I'm looking to open up a port 5566 on my server. I've added 5566 to SYSTEM > FIREWALL.
    My router doesn't block any ports.

    This site http://www.yougetsignal.com/tools/open-ports/
    shows Port 5566 is closed on

    IP Tables

    PAROLE     tcp  --  anywhere             anywhere            tcp dpt:5566
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:domain
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:mysql
    ACCEPT     udp  --  anywhere             anywhere            udp dpt:5566
    DROP       icmp --  anywhere             anywhere
    DROP       all  --  anywhere             anywhere
    When I attempted to telnet from my workstation to ip address it failed and was trying to open port 23.

    I need to make sure that port 5566, which is what the API uses to connect the web pages to the database is allowed through the firewall.

    Does anyone know how I can troubleshoot this?

    Attached Files:

    Last edited: Apr 12, 2013
  2. markc

    markc Member

    Perhaps try telnet 5566 (no colon).
  3. onastvar

    onastvar Member

    still no luck

    telnet 5566
    Connecting To not open connection to the host, 
    on port 5566: Connect failed
  4. markc

    markc Member

    You've got pings disabled so maybe remove this rule until you have everything working...

    DROP icmp -- anywhere anywhere

    Then install nmap and nmap and that will show you all the ports open on this IP.
  5. onastvar

    onastvar Member

    Thanks Markc! Do you know how do I remove rule:

    DROP icmp -- anywhere anywhere
    -su: DROP: command not found
    i installed nmap, which shows open ports, 5566 isn't on the list. It looks like change made in SYSTEM > FIREWALL aren't being respected.

    Starting Nmap 5.00 ( http://nmap.org ) at 2013-04-13 10:40 CDT
    Interesting ports on server.server1.com (
    Not shown: 984 closed ports
    21/tcp   open  ftp
    22/tcp   open  ssh
    25/tcp   open  smtp
    53/tcp   open  domain
    80/tcp   open  http
    110/tcp  open  pop3
    111/tcp  open  rpcbind
    143/tcp  open  imap
    443/tcp  open  https
    465/tcp  open  smtps
    587/tcp  open  submission
    993/tcp  open  imaps
    995/tcp  open  pop3s
    3306/tcp open  mysql
    8080/tcp open  http-proxy
    8081/tcp open  blackice-icecap
    Nmap done: 1 IP address (1 host up) scanned in 0.17 seconds
  6. markc

    markc Member

    Presuming it's an INPUT rule on then try...

    iptables -D INPUT -p icmp -j DROP

    and then try and ping from your desktop machine. You can also try netstat -tanup | grep 5566 on your server to see if any daemon is listening to those ports.
    Last edited: Apr 13, 2013
  7. onastvar

    onastvar Member

    Thanks Markc. Before I ran

    iptables -D INPUT -p icmp -j DROP

    will I be able to reverse it and how?
  8. markc

    markc Member

    Yes. It's probably part of your default firewall rules so if you rebooted I am guessing it would come back anyway.

    iptables -A INPUT -p icmp -j DROP

    This does not have a lot to do with your original problem other than to allow easier testing by pinging your server from external hosts. Also, the ports may be missing from the nmap output simply because whatever server process is supposed to be providing a service for those ports is not actually up and running on your server.
    Last edited: Apr 13, 2013
  9. onastvar

    onastvar Member

    I've sent email to tech support of the application I'm installing to check what services or server processes need to run on port 5566.
  10. onastvar

    onastvar Member

    Application is using API service. I'm getting this error

    Warning: fsockopen(): unable to connect to ssl:// (Connection refused) Error => Cannot Open Socket to Server. [Failure]

    Anyone know how to fix this?
  11. onastvar

    onastvar Member

    Please ignore/delete this thread/post.

    Just found out, the application requires MSSQL database, and API service is windows based and must be installed on a Windows machine. There is no Linux package for the database, client and services.
  12. onastvar

    onastvar Member

    Issue SOLVED

Share This Page