logs

Discussion in 'Tips/Tricks/Mods' started by Richard7890, May 16, 2009.

  1. Richard7890

    Richard7890 New Member

    Hi,

    I have previously been using qmail with qmail-scanner, which i had setup to show all spam ratings in the logs (/var/spool/qmailscan/qmail-queue.log) . like this :

    Sat, 16 May 2009 12:37:57 EST:4462: SA: REPORT hits = 15.1/4.0
    0.0 HTML_MESSAGE BODY: HTML included in message
    1.8 MIME_QP_LONG_LINE RAW: Quoted-printable line longer than 76 chars
    1.5 RAZOR2_CF_RANGE_E8_51_100 Razor2 gives engine 8 confidence level
    above 50%
    [cf: 100]
    1.5 RAZOR2_CF_RANGE_E4_51_100 Razor2 gives engine 4 confidence level
    above 50%
    [cf: 100]
    3.5 RAZOR2_CHECK Listed in Razor2 (http://razor.sf.net/)
    0.5 RAZOR2_CF_RANGE_51_100 Razor2 gives confidence level above 50%
    [cf: 100]
    3.5 DCC_CHECK Listed in DCC (http://rhyolite.com/anti-spam/dcc/)
    0.0 DIGEST_MULTIPLE Message hits more than one network digest check
    2.1 DRUGS_ERECTILE_OBFU Obfuscated reference to an erectile drug
    0.6 DRUGS_ERECTILE Refers to an erectile drug
    Sat, 16 May 2009 12:37:57 EST:4462: SA: yup, this smells like SPAM - hits=15.1 - deleting message...

    how can i make postfix and amavis show this in the logs ?


    Thanks,

    Richard
     
  2. till

    till Super Moderator

    Change the loggin level in the amavisd 50-user configuration file.
     
  3. Richard7890

    Richard7890 New Member

    Thanks Till,

    I see what happened. I had changed the $DO_SYSLOG Variable to 1.

    #
    # Enable Logging
    #

    $DO_SYSLOG = 0;
    $LOGFILE = "/var/log/amavis.log"; # (defaults to empty, no log)

    Which then doesn't write the /var/log/amavisd.log file. After switching back to '0' the logs showed up.

    Richard.
     

Share This Page