Login screen broken after update from 3.0.3 to 3.0.5

Discussion in 'Installation/Configuration' started by Julian, Oct 7, 2013.

  1. Julian

    Julian Member

    Hi,

    I made update from 3.0.3 to 3.0.5 and now I can't login to ispconfig.
    The page is loading, I have the header and the footer but I don't the the fields where to put the username, password and submit button.

    The server is debian 6.0.6
    All the websites are working.

    Can anyone help me?
    Thank you
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the global apache error.log for errors.
     
  3. Julian

    Julian Member

    [Mon Oct 07 15:01:16 2013] [warn] [client ip] mod_fcgid: stderr: PHP Notice: A session had already been started - ignoring session_start() in /usr/local/ispconfig/interface/web/js/scrigo.js.php on line 2, referer: https://ip:50443/
    [Mon Oct 07 15:01:16 2013] [warn] [client ip] mod_fcgid: stderr: PHP Notice: A session had already been started - ignoring session_start() in /usr/local/ispconfig/interface/web/js/scrigo.js.php on line 2, referer: https://ip:50443/
    [Mon Oct 07 15:02:30 2013] [notice] caught SIGTERM, shutting down
    [Mon Oct 07 15:02:31 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Oct 07 15:02:31 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Oct 07 15:02:31 2013] [notice] Digest: generating secret for digest authentication ...
    [Mon Oct 07 15:02:31 2013] [notice] Digest: done
    [Mon Oct 07 15:02:32 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Oct 07 15:02:32 2013] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze15 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    [Mon Oct 07 15:02:34 2013] [warn] [client ip] mod_fcgid: stderr: PHP Notice: A session had already been started - ignoring session_start() in /usr/local/ispconfig/interface/web/js/scrigo.js.php on line 2, referer: https://ip:50443/
    [Mon Oct 07 15:02:34 2013] [warn] [client ip] mod_fcgid: stderr: PHP Notice: A session had already been started - ignoring session_start() in /usr/local/ispconfig/interface/web/js/scrigo.js.php on line 2, referer: https://ip:50443/
    [Mon Oct 07 15:09:38 2013] [notice] caught SIGTERM, shutting down
    [Mon Oct 07 15:09:39 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Oct 07 15:09:39 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Mon Oct 07 15:09:39 2013] [notice] Digest: generating secret for digest authentication ...
    [Mon Oct 07 15:09:39 2013] [notice] Digest: done
    [Mon Oct 07 15:09:39 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Mon Oct 07 15:09:39 2013] [notice] Apache/2.2.16 (Debian) DAV/2 mod_fcgid/2.3.6 PHP/5.3.3-7+squeeze15 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2010-08-16) mod_ssl/2.2.16 OpenSSL/0.9.8o configured -- resuming normal operations
    [Mon Oct 07 15:09:42 2013] [warn] [client ip] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Mon Oct 07 15:09:42 2013] [error] [client ip] Premature end of script headers: index.php
    [Mon Oct 07 15:09:43 2013] [warn] [client ip] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Mon Oct 07 15:09:43 2013] [error] [client ip] Premature end of script headers: index.php


    this is the log from apache

    Can you help me?

    Thank you
     
  4. Julian

    Julian Member

    Can anyone help me?
     
  5. betafer

    betafer New Member

    We have same mod_fcgid errors in our apache log file ...
     
  6. scenic2

    scenic2 New Member

    I have two servers with same problem. Both with OpenSuse 12.2

    My apache error log:

    [Mon Nov 04 08:16:51 2013] [warn] [client MY EXTERNAL IP] mod_fcgid: error reading data, FastCGI server closed connection, referer: https://MY DOMAIN:MY ISPCONFIG PORT/
    [Mon Nov 04 08:16:51 2013] [error] [client MY EXTERNAL IP] Premature end of script headers: scrigo.js.php, referer: https://MY DOMAIN:MY ISPCONFIG PORT/



    I think the problem is about apache2-mod_fcgid because in my case the problem manifested after update my server with "zypper update".

    Here is my zypper history:

    2013-10-31 22:20:50|install|apache2-mod_fcgid|2.3.6-9.4.1|x86_64||repo-update|90d1ff18267286bfdbf4a5d0b5b1f2e1c068725b7f2996272acf58b433b91e05
    # 2013-10-31 22:20:51 apparmor-parser-2.8.2-2.11.1.x86_64.rpm installed ok
    # Additional rpm output:
    # redirecting to systemctl
    #
    2013-10-31 22:20:51|install|apparmor-parser|2.8.2-2.11.1|x86_64||repo-update|d5d86f365f253e57fa5eae86a52561e579b85e362164953b03dab79e202cad00
    2013-10-31 22:20:52|install|timezone|2013h-1.40.1|x86_64||repo-update|19fea37b76414739c14a7b182eb3e7e4950e69f496263944024f41fceac99b40
    2013-10-31 22:20:52|install|timezone-java|2013h-1.40.1|noarch||repo-update|68a6111d8b385316c6b7bfe8a44096f231664c28a2e84bdde57f3756eb10bf48
    2013-10-31 22:20:53|install|xorg-x11-Xvnc|7.6_1.12.3-1.37.1|x86_64||repo-update|bca94dc5cc54b7fbfdca51d009fd8fc16366e7f4a0ba2019da24be2d1d593a31
    # 2013-10-31 22:20:53 xorg-x11-server-7.6_1.12.3-1.37.1.x86_64.rpm installed ok
    # Additional rpm output:
    # Updating /etc/sysconfig/displaymanager...
    # /usr/bin/Xorg: cannot verify root:root 0755 - not listed in /etc/permissions
    #
    2013-10-31 22:20:53|install|xorg-x11-server|7.6_1.12.3-1.37.1|x86_64||repo-update|5062307535b5c16a034c03fc92394363641beb141499a6439d26e845a0927f4d
    2013-10-31 22:20:55|install|hplip-hpijs|3.12.4-3.6.1|x86_64||repo-update|700f5b6ca3084bcb34efcad6f7036bbec5f23bdef4518a913072196d40df2570
    2013-10-31 22:20:55|install|hplip-sane|3.12.4-3.6.1|x86_64||repo-update|11b29771bee45652424415f26f028fad30986e1ba7ca844a201f48a69a356baf
    2013-10-31 22:21:01|install|hplip|3.12.4-3.6.1|x86_64||repo-update|ae1de2d57e9d7242b66e09bc2769b8a05c89298cb42f36551abe4376b37728bf


    In this morning I tried to reinstall apache2-mod_fcgid but... "Nothing to do"

    zypper install apache2-mod_fcgid
    Loading repository data...
    Reading installed packages...
    'apache2-mod_fcgid' is already installed.
    There is an update candidate for 'apache2-mod_fcgid', but it is from different vendor. Use 'zypper install apache2-mod_fcgid-2.3.7-28.2.x86_64' to install this candidate.
    Resolving package dependencies...

    Nothing to do.


    For the moment I have no idea what should I do but I'm thinking.
    Any help is appreciated.
    Thank You
     
    Last edited: Nov 4, 2013
  7. scenic2

    scenic2 New Member

    Still in trouble... :confused:

    Anyone can help me?

    Thanks
     
  8. scenic2

    scenic2 New Member

    PROBLEM SOLVED!

    apache2-mod_fcgid

    Like I supposed in my previous post the problem was with apache2-mod_fcgid module.
    To resolve the problem you need to uninstall and reinstall this module.
    (probably more than one time – I don’t know why but in my case works)
    So after uninstall and reinstall again and again… :) Problem was solved!
    Correct version in my case was apache2-mod_fcgid-2.3.6-9.4.1.x86_64.
    To retrieve correct version of this module you need to disable following repositories:
    "http://download.opensuse.org/repositories/Apache:/Modules/Apache_openSUSE_12.2/"

    Thank You
     
    Last edited: Nov 11, 2013
  9. scenic2

    scenic2 New Member

    Now, when this problem was solved, I have another question:

    To update or not to update my server?

    I have a list of update to made but I'm afraid to do these updates because of previous problem. Any advice?

    How can I made a backup of my server to restore later in case of problem?
    Something like system restore in Windows exists in OpenSuse 12.2?
     

Share This Page