Login password isn't working

Discussion in 'General' started by briand0713, Sep 21, 2011.

  1. briand0713

    briand0713 New Member

    I set the password a couple months ago and wrote it down as far as I knew. When I tried it, I kept getting an incorrect response. I also tried the default admin/admin password but that also failed. I was wondering if there's anyway I could manually adjust the password by editting config files while SSHing into the shell and if so, what would the procedure be?

    OS: OpenSUSE v11.2
    ISPConfig: v3
     
  2. Mark_NL

    Mark_NL New Member

  3. briand0713

    briand0713 New Member

    thanks but this wasn't the information I needed but it will come in handy if I ever lose my mysql password.

    What I need is the admin client login information for ISPConfig so I can login to the admin account when I goto http://192.168.1.110:8080

    EDIT: Ok I checked the website you mentioned. I got this error when inputting the mysql password:

    Code:
     mysql -u root -p
    Enter password:
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)
    
     
    Last edited: Sep 21, 2011
  4. Mark_NL

    Mark_NL New Member

    Is mysql running?

    Code:
    netstat -tapn | grep 3306
    ls -al /var/run/mysql/
    cat /etc/mysql/my.cnf | egrep -v '^#|^$'
    
    show us the output of these commands
     
  5. briand0713

    briand0713 New Member

    This is the output of those commands:

    Code:
    server1:~ # netstat -tapn | grep 3306
    server1:~ # ls -al /var/run/mysql/
    total 12
    drwxr-xr-x  2 mysql mysql 4096 Sep 20 19:24 .
    drwxr-xr-x 23 root  root  4096 Sep 20 19:25 ..
    -rw-r--r--  1 root  root    22 Sep 20 19:24 tmpdir
    server1:~ # cat /etc/mysql/my.cnf | egrep -v '^#|^$'
    cat: /etc/mysql/my.cnf: No such file or directory
    
    my.cnf is located in /etc/ unless if that's a completely different file all together. Here's what I got when I did: cat /etc/my.cnf | egrep -v '^#|^$'


    Code:
    server1:/etc # cat /etc/my.cnf | egrep -v '^#|^$'
    [client]
    port            = 3306
    socket          = /var/run/mysql/mysql.sock
    [mysqld]
    port            = 3306
    socket          = /var/run/mysql/mysql.sock
    datadir = /var/lib/mysql
    skip-locking
    key_buffer_size = 16M
    max_allowed_packet = 1M
    table_open_cache = 64
    sort_buffer_size = 512K
    net_buffer_length = 8K
    read_buffer_size = 256K
    read_rnd_buffer_size = 512K
    myisam_sort_buffer_size = 8M
    log-bin=mysql-bin
    binlog_format=mixed
    server-id       = 1
    [safe_mysqld]
    log-error       = /var/log/mysql/mysqld.log
    socket          = /var/run/mysql/mysql.sock
    [mysqldump]
    socket          = /var/run/mysql/mysql.sock
    quick
    max_allowed_packet = 16M
    [mysql]
    no-auto-rehash
    [myisamchk]
    key_buffer_size = 20M
    sort_buffer_size = 20M
    read_buffer = 2M
    write_buffer = 2M
    [mysqlhotcopy]
    interactive-timeout
    [mysqld_multi]
    mysqld     = /usr/bin/mysqld_safe
    mysqladmin = /usr/bin/mysqladmin
    log        = /var/log/mysqld_multi.log
    
     
  6. Mark_NL

    Mark_NL New Member

    MySQL is not running, i bet that's why you can't log in at all :)

    If you start mysql, you should mostlikely be able to log into the ispconfig admin again
     
  7. briand0713

    briand0713 New Member

    hmm strange. Probably the reason I couldn't login to ISPConfig in the first place. I tried to START and RESTART mysql but I don't think it worked

    Code:
    server1:/etc # chkconfig --add mysql
    mysql                     0:off  1:off  2:on   3:on   4:off  5:on   6:off
    server1:/etc # /etc/init.d/mysql start
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
                                                                                               done
    server1:/etc # mysql -u root -p
    Enter password:
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)
    server1:/etc # /etc/init.d/mysql restart
    Restarting service MySQL
    Shutting down service MySQL                                                                done
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
                                                                                               done
    
     
  8. briand0713

    briand0713 New Member

    I think I solved the problem. I guess my harddrive was filled up. I was having similar problems trying to get my Minecraft server running. I thought it was just something local but instead it was the harddrive. I cleared up some files and now mysql, ispconfig, and minecraft are running.

    thanks
     
  9. Mark_NL

    Mark_NL New Member

    hahaha, nice one :)

    (gotta keep that one in mind when trouble shooting next time)
     

Share This Page