login frontend fail. Empty page.

Discussion in 'General' started by yoplait, Jan 16, 2012.

  1. yoplait

    yoplait Member

    it seems a long time since i came there -and it's a good thing !-, because i didn't notice any problem.

    But I have one today...
    Some of my clients can't log in the ispconfig frontend. When they log in, the page is empty except the ispconfig logo, the logout button (which doesn't work) and the "powered by ISPconfig" term.

    It didn't work on, so i updated today, but nothing changes...
    I can't see a word about it in the forum or in the bug tasklist of ispconfig 3...

    I tried to change the theme of these users, but nothing changed.

    Maybe a clue : i can't come back to log as an admin, except if i close my firefox (ctrl+F5 don't do anything).
    It seems that's users i created in the 2 years, but not the earliers...(not sure about that...)

    Excuse me for my english .(french inside :D ).
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Might be a crashed database table. Check the ispconfig mysql database in phpmyadmin.
  3. yoplait

    yoplait Member

    Everything seems ok in the databases ... can you tell my how to see that exactly ?
    I went on phpmyadmin, on dbispconfig, selected all tables and check : OK for all.
  4. yoplait

    yoplait Member

    I continued to login without any succes for these account ... :(
    I checked all the databases with "mysqlcheck --all-databases", all seems OK.
    I tried to change some parameters in the user's limits, no succes...
    I tried to find a log about the http connexions, nothing for ispconfig...

    I really don't know how to do now ...

    Do you have an idea on what log file I should look after ?
    If I create a new user, is there any problem if I want to reaffect the website of the one which doesn't work ? (but i'm really not sure this new one will work !!)

    This bug occured on every kind of web browser (firefox, chrome...Etc).
    Ispconfig is installed on Debian, well updated, on an OVH server.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look in the apache error.log.
  6. yoplait

    yoplait Member

    i've watched every error.log in /var/log/ispconfig and /var/log/apache2 but I can't see anything about the moment when I try this log in ...

    Is there a test or something, to know if this user logged in with succes ?
    It seems strange that the browser need to be closed/opened to have the possibility to log in again, isn't it ? (or, to say it in a different way : the "log out" button don't seem to work in my case...)

    I tried to see the difference in the ispconfig database between a good and a bad client.. I can't see anything strange about it ... :(

    Any other idea ?
    (and thank you for your help ;) ).
  7. yoplait

    yoplait Member

    I come back to you to tell you that the problem is solved.

    After trying a lot of things, I went to "System", edited the user and changed the theme to "default". And then it worked fine !
    I did it for every users that didn't work and it seems that the problem has gone.

    During my tests, i wanted to create a new client to copy the data from the bug-user to this new user but i saw some problems. I tell you that, just in case it could help you :
    - Impossible to change the database's client, it said the name of the database can't be changed.
    - When I change the client of a FTP user, the prefix is added to the previous one. (for exemple c11user became c22c11user).
    That's all !

    I hope it can help.

    Thanks for your help, anyway ;) .

Share This Page