Login at Dovecot with POP3 fails

Discussion in 'Installation/Configuration' started by 4integration, Jul 6, 2007.

  1. 4integration

    4integration New Member

    Hello,

    I have reinstalled my server and are using Dovecot with IMAP + POP3.

    When using IMAP everything works fine but for POP3 accounts I get in Thunderbird:
    In the syslog I don't find very much
    Any idea what could be wrong?
     
  2. Hans

    Hans Moderator ISPConfig Developer

    After installing Dovecot, you have to configure your /etc/dovecot/dovecot.conf, did you do that already?

    Probably, you also see in ISPConfig that pop3 is not running...
     
  3. 4integration

    4integration New Member

    I am not using using ISPConfig and just realized that I posted in the wrong installation/configuration forum, sorry!

    Yes, I have configured dovecot.conf
    Parts of the setup is from these sites:
    http://johnny.chadda.se/2007/04/15/...cot-with-mysql-and-tlsssl-postgrey-and-dspam/
    http://www.howtoforge.com/virtual_postfix_mysql_quota_courier_ubuntu_edgy

    netstat -tap
    Code:
    [email protected]:/var/log# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN     5239/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN     6719/master
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     5359/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     5758/dovecot
    tcp        0      0 *:imap2                 *:*                     LISTEN     5758/dovecot
    tcp        0      0 *:webmin                *:*                     LISTEN     5962/perl
    tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN     5271/cupsd
    tcp        0      0 *:smtp                  *:*                     LISTEN     6719/master
    
    Shouldn't saslauthd be running?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Saslauthd has nothing to do with fetching mails, it's used only for sending. And you don't find saslauthd in the netstat output, you must search the output of
    Code:
    ps aux
    for it.

    What's in your dovecot.conf?
     
  5. 4integration

    4integration New Member

    Hello,

    I think I got it working with the setting:
    disable_plaintext_auth = no
    Is this good or bad? Other solution??

    Below you will find the dovecot.conf (with the comments removed)
    Code:
    ## Dovecot configuration file
    
    
    base_dir = /var/run/dovecot/
    protocols = imap pop3
    protocol imap {
    	listen = *:143
    	ssl_listen = *:993
    }
    protocol pop3 {
    	listen = *:110
    	ssl_listen = *:995
    }
    disable_plaintext_auth = no
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    syslog_facility = mail
    ssl_cert_file = /etc/ssl/domain/mailserver/mail-cert.pem
    ssl_key_file = /etc/ssl/domain/mailserver/mail-key.pem
    ssl_verify_client_cert = yes
    ssl_parameters_regenerate = 168
    verbose_ssl = yes
    mail_location = maildir:/var/vmail/%d/%u
    mail_extra_groups = mail
    mail_debug = yes
    first_valid_uid = 5000
    last_valid_uid = 5000
    protocol imap {
      login_executable = /usr/lib/dovecot/imap-login
      mail_executable = /usr/lib/dovecot/imap
      imap_max_line_length = 65536
      imap_client_workarounds = outlook-idle
    }
    protocol pop3 {
      login_executable = /usr/lib/dovecot/pop3-login
      mail_executable = /usr/lib/dovecot/pop3
      pop3_uidl_format = %08Xu%08Xv
      pop3_client_workarounds =outlook-no-nuls oe-ns-eoh
    }
    
    protocol lda {
      postmaster_address = [email protected]
      sendmail_path = /usr/lib/sendmail
      auth_socket_path = /var/run/dovecot/auth-master
    }
    auth_verbose = no
    auth_debug = yes
    auth_debug_passwords = yes
    auth default {
      mechanisms = plain
      passdb sql {
        args = /etc/dovecot/dovecot-sql.conf
      }
      userdb sql {
        args = /etc/dovecot/dovecot-sql.conf
      }
      user = root
      socket listen {
        master {
          path = /var/run/dovecot/auth-master
          mode = 0660
          user = vmail
          group = mail
        }
        client {
          path = /var/spool/postfix/private/auth
          mode = 0660
          user = postfix
          group = postfix
        }
      }
    }
    dict {
    }
    plugin {
    }
     
  6. falko

    falko Super Moderator ISPConfig Developer

    That's correct. :)
     

Share This Page