Logged out after 3 seconds in roundcube

Discussion in 'Installation/Configuration' started by Masterjoa, Feb 12, 2012.

  1. Masterjoa

    Masterjoa New Member

    Hi,
    I have a problem with roundcube (Debian 6 + ispconfig with apache and nginx reverse-proxy). I am logged out after 3 seconds. So I can't read my emails !
    Here is the log (/var/log/mail.log):
    Code:
    Feb 12 15:45:02 ks307214 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Feb 12 15:45:02 ks307214 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Feb 12 15:45:02 ks307214 postfix/smtpd[17902]: warning: cannot get RSA private key from file /etc/postfix/smtpd.key: disabling TLS support
    Feb 12 15:45:02 ks307214 postfix/smtpd[17902]: warning: TLS library problem: 17902:error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch:x509_cmp.c:406:
    Feb 12 15:45:02 ks307214 postfix/smtpd[17902]: connect from localhost.localdomain[127.0.0.1]
    Feb 12 15:45:02 ks307214 postfix/smtpd[17902]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
    Feb 12 15:45:02 ks307214 postfix/smtpd[17902]: disconnect from localhost.localdomain[127.0.0.1]
    Feb 12 15:46:28 ks307214 dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Feb 12 15:46:28 ks307214 dovecot: IMAP([email protected]): Disconnected: Logged out bytes=39/449
    Feb 12 15:46:28 ks307214 dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Feb 12 15:46:28 ks307214 dovecot: IMAP([email protected]): Disconnected: Logged out bytes=303/2268
    Can someone help me please ?
     
    Last edited: Feb 12, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

    Not sure, but maybe it has something to do with your reverse proxy configuration?

    Does the same happen if you access RoundCube on Apache?
     
  3. Masterjoa

    Masterjoa New Member

    It worked fine with apache before.
    But I don't know how to go to roundcube using only apache (only for roundcube while keeping the reverse proxy for the other http and https requests). How can I do that ?
     
    Last edited: Feb 13, 2012
  4. falko

    falko Super Moderator ISPConfig Developer

    I guess your Apache is running on a different port, so just append that port to your hostname when you try to access RoundCube.
     
  5. Masterjoa

    Masterjoa New Member

    I still try but it doesn't work. :(
    ssl_error_rx_record_too_long
    EDIT: It work ! I forgot to change the port in /etc/apache2/sites-enabled/default-ssl. I can go to roundcube using only apache.
    Thanks :)
     
    Last edited: Feb 14, 2012

Share This Page