local-host-names and subdomains keeps unwanted domains

Discussion in 'Installation/Configuration' started by grocal, Sep 13, 2007.

  1. grocal

    grocal New Member

    Here's the situation.

    We have a domain. Let's say it's example.domain. There's a DNS server somewhere for this domain and there's a mail server for emails from/to this domain too. Now, there's a linux machine with ISPConfig on it on which I want to host sites (without email sending support) for home.example.domain. So, I edit DNS zone files for domain example.domain on its DNS server to home.example.domain point to ISPConfig managed server. Ping/traceroute to home.example.domain works just fine pointing to the correct machine.

    In ISPConfig you have to add new site and it's address by splitting domain and host part of address. So you can only enter home as host and example.domain as domain. This way example.domain gets on to local-host-names file for postfix. Do you know what that gives? You cannot send email to any address from example.domain (like [email protected]) from any other account/domain that is hosted on ISPConfig machine because postfix thinks that example.domain is on local machine and tries to send it locally. The problem persists if you add www as host and home.example.domain as domain while adding new site - still you get home.example.domain and example.domain added to local-host-names file.

    Is there some option to force ISPConfig not to add domain to local-host-names? Is there a correct method for adding subdomains as new sites without using www prefix/host?

    And one more thing. I've added some site, it worked for a couple of days then I got rid of it from ISPConfig using www admin panel. Why local-host-names still got this domain in it? Why there's an entry in mysql table isp_isp_domain?

  2. falko

    falko Super Moderator ISPConfig Developer

    Yes. Go to the Options tab and set the mailserver to external. Do the same for the Co-Domains.

    Please check your Co-Domains.
  3. grocal

    grocal New Member

    It was and it is set to external. Still main domain ends up in local-host-names after hitting SAVE button (host name is set to www, domain name to someserver.mydomain.domain and mydomain.domain shows up in local-host-names all the time). There's also other domain which is nowhere in admin panel (has been removed) but after any SAVE action for site it appears in local-host-names again. It's still in database. It's not correct since this domain is on some other server for a couple od days now and after any change in ISPConfig it shows up in local-host-names preventing users from sending email to that domain.
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you empty all recycle bins? Are you sure you set the mail server to external for the main domain of the web site and also for the Co-Domains?

    Any errors in /home/admispconfig/ispconfig/ispconfig.log? What's the output of
    ls -la /root/ispconfig
  5. jbravo

    jbravo New Member

    I'd like to ask this question regarding using ISPConfig as mailserver only. I have additional distro apache for webmail only and do not want vhosts with ServerName www* (webmail.domain.com only beacuse main domain website resides on different server).
    Ofcourse ISPConfig is not authoritative (both external dns servers for this domain) for this example domain so this is only "cosmetic" issue - but i like things setup 100%.

    Seems that ISPConfig adds co-domain www* automatically and we can not change it easily - i'm right?
  6. falko

    falko Super Moderator ISPConfig Developer

    Simply delete that Co-Domain.
  7. jbravo

    jbravo New Member

    ISPConfig did it:(
    What I did was:
    setup site let's say: "domain.com" (host part empty).
    ISPConfig automatically added "www" as hostname - and there is no codomain "www" - so i can not delete it. But it created "domain.com" as codomain!

    Even trying to empty hostname part in "Basis" tab did nothing.

    So it looks like i need just to live with it and hope ispconfig v3 implement this any many other ispconfig features/wishes i have:)

    UPDATE: tried it again - and i still can see "www" in hostname field - but "www" prefix dissapeard from postfix and apache config files. I've restarted ispconfig to be sure that is persist - seems that it is!

    UPDATE#2: i give up. After adding some new accounts "www" rised again;)
    Last edited: Dec 6, 2007

Share This Page