LOAD DATA LOCAL INFILE dosen't work

Discussion in 'Installation/Configuration' started by destine, Feb 11, 2014.

  1. destine

    destine Member

    Hi

    I have another problem.

    On Debian 7 I have installed mysql 5.5.35 and mysql 5.4.24.
    My problem is that, LOAD DATA LOCAL INFILE dosen't work.

    I get error: LOAD DATA LOCAL INFILE 'test.csv' INTO TABLE test -> The used command is not allowed with this MySQL version

    I added to my my.cnf

    [client]
    loose-local-infile = 1

    [mysqld]
    local-infile = 1

    [mysql]
    local-infile = 1

    when I'm checking settings for mysql I got:
    mysql> show global variables like 'local_infile';
    +---------------+-------+
    | Variable_name | Value |
    +---------------+-------+
    | local_infile | ON |
    +---------------+-------+
    1 row in set (0.00 sec)


    fom my connect.php
    $link = new mysqli($db_host, $db_user, $db_pass, $db_dbase);

    also tried
    $link = new mysqli($db_host, $db_user, $db_pass, $db_dbase, 128);

    and test load infile
    <?
    $sql = "LOAD DATA LOCAL INFILE 'test.csv' INTO TABLE test";
    db_query($sql);

    ?>


    any Idea ? how to solved this problem ?
     
    Last edited: Feb 11, 2014
  2. destine

    destine Member

    Problem almost solved

    Hi again

    I almost solved this problem but now I need to change template in ispconfig3.

    because ispconfig3 by default is making web directory with permissions 710 I need to change this to 711. But I don't want to do by hand every time when I added new account. So I need to edit template

    how can I do this, where can I find this template
     

Share This Page