list of messages through IMAP and WEBMAIL not identical

Discussion in 'Installation/Configuration' started by crazyivan, Oct 18, 2013.

  1. crazyivan

    crazyivan New Member HowtoForge Supporter

    Crew,

    I've setup ISPConfig using the HowTo's on this site. I'm running Debian Wheezy and ISPConfig 3.0.5.3.

    When I sent my self an e-mail from an external (and valid) mail address the mail shows in my IMAP mail client (Apple mail) and in my webmail (roundcube). No problem there. (Sending mail is not an issue)

    Incomming mail, received correctly (anonymized):
    Code:
    Oct 18 08:56:27 mail postfix/smtpd[14708]: connect from mail-ee0-f52.google.com[gmail ip adress]
    Oct 18 08:56:27 mail postfix/smtpd[14708]: 8CF4D40D95: client=mail-ee0-f52.google.com[gmail ip adress]
    Oct 18 08:56:27 mail postfix/cleanup[14749]: 8CF4D40D95: message-id=<[email protected]>
    Oct 18 08:56:27 mail postfix/qmgr[14505]: 8CF4D40D95: from=<[email protected]>, size=1821, nrcpt=1 (queue active)
    Oct 18 08:56:27 mail postfix/smtpd[14708]: disconnect from mail-ee0-f52.google.com[gmail ip adress]
    Oct 18 08:56:27 mail amavis[14340]: (14340-01) ESMTP::10024 /var/lib/amavis/tmp/amavis-20131018T085627-14340-06R_GKiK: <[email protected]> -> <[email protected]> SIZE=1821 Received: from mailserver.ispconfigdomain.com ([127.0.0.1]) by localhost (mailserver.ispconfigdomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <[email protected]>; Fri, 18 Oct 2013 08:56:27 +0200 (CEST)
    Oct 18 08:56:27 mail amavis[14340]: (14340-01) Checking: TCvI7AyLUVdH [gmail ip adress] <[email protected]> -> <[email protected]>
    Oct 18 08:56:27 mail amavis[14340]: (14340-01) p001 1 Content-Type: text/plain, size: 2 B, name: 
    Oct 18 08:56:33 mail postfix/smtpd[14755]: connect from localhost.localdomain[127.0.0.1]
    Oct 18 08:56:33 mail postfix/smtpd[14755]: 030D740E25: client=localhost.localdomain[127.0.0.1]
    Oct 18 08:56:33 mail postfix/cleanup[14749]: 030D740E25: message-id=<[email protected]>
    Oct 18 08:56:33 mail postfix/qmgr[14505]: 030D740E25: from=<[email protected]>, size=2279, nrcpt=1 (queue active)
    Oct 18 08:56:33 mail amavis[14340]: (14340-01) FWD from <[email protected]> -> <[email protected]>,BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 030D740E25
    Oct 18 08:56:33 mail amavis[14340]: (14340-01) Passed CLEAN {RelayedInbound}, [gmail ip adress]:64086 [94.210.110.238] <[email protected]> -> <[email protected]>, Queue-ID: 8CF4D40D95, Message-ID: <[email protected]>, mail_id: TCvI7AyLUVdH, Hits: -0.799, size: 1821, queued_as: 030D740E25, 5447 ms
    Oct 18 08:56:33 mail amavis[14340]: (14340-01) TIMING-SA total 5285 ms - parse: 1.67 (0.0%), extract_message_metadata: 19 (0.4%), poll_dns_idle: 5026 (95.1%), get_uri_detail_list: 0.61 (0.0%), tests_pri_-1000: 8 (0.2%), tests_pri_-950: 1.21 (0.0%), tests_pri_-900: 1.26 (0.0%), tests_pri_-400: 0.82 (0.0%), tests_pri_0: 163 (3.1%), check_dkim_signature: 10 (0.2%), check_spf: 110 (2.1%), check_pyzor: 0.26 (0.0%), tests_pri_500: 4996 (94.5%), learn: 64 (1.2%), get_report: 0.83 (0.0%)
    Oct 18 08:56:33 mail postfix/smtp[14750]: 8CF4D40D95: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=5.5, delays=0.03/0.01/0.01/5.4, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 030D740E25)
    Oct 18 08:56:33 mail postfix/qmgr[14505]: 8CF4D40D95: removed
    Oct 18 08:56:33 mail amavis[14340]: (14340-01) size: 1821, TIMING [total 5460 ms] - sql-prepare: 5 (0%)0, SMTP greeting: 2 (0%)0, SMTP EHLO: 1 (0%)0, SMTP pre-MAIL: 1 (0%)0, mkdir tempdir: 1 (0%)0, create email.txt: 0 (0%)0, sql-connect: 7 (0%)0, lookup_sql: 2 (0%)0, SMTP pre-DATA-flush: 2 (0%)0, SMTP DATA: 25 (0%)1, check_init: 1 (0%)1, digest_hdr: 1 (0%)1, digest_body: 0 (0%)1, mkdir parts: 4 (0%)1, mime_decode: 8 (0%)1, get-file-type1: 17 (0%)1, parts_decode: 0 (0%)1, check_header: 1 (0%)1, AV-scan-1: 6 (0%)2, lookup_sql: 10 (0%)2, spam-wb-list: 1 (0%)2, SA parse: 6 (0%)2, SA check: 5278 (97%)98, decide_mail_destiny: 7 (0%)99, notif-quar: 0 (0%)99, fwd-connect: 21 (0%)99, fwd-mail-pip: 3 (0%)99, fwd-rcpt-pip: 0 (0%)99, fwd-data-chkpnt: 0 (0%)99, write-header: 1 (0%)99, fwd-data-contents: 0 (0%)99, fwd-end-chkpnt: 6 (0%)99, prepare-dsn: 1 (0%)99, main_log_entry: 37 (1%)100, update_snmp: 2 (0%)100, SMTP pre-response: 0 (0%)100, SMTP response: 4 (0%)100, unlink-1-files: 0 (0%)100, rundown: 1 (0%)100
    Oct 18 08:56:33 mail amavis[14340]: (14340-01) extra modules loaded: unicore/lib/Alpha/Y.pl, unicore/lib/Nt/De.pl, unicore/lib/Perl/Alnum.pl, unicore/lib/Perl/SpacePer.pl
    Oct 18 08:56:33 mail dovecot: auth-worker(14758): mysql(localhost): Connected to database dbispconfig
    Oct 18 08:56:33 mail dovecot: lda([email protected]): sieve: msgid=<[email protected]>: stored mail into mailbox 'INBOX'
    Oct 18 08:56:33 mail postfix/pipe[14756]: 030D740E25: to=<[email protected]>, relay=dovecot, delay=0.1, delays=0.01/0.02/0/0.08, dsn=2.0.0, status=sent (delivered via dovecot service)
    Oct 18 08:56:33 mail postfix/qmgr[14505]: 030D740E25: removed
    I've setup my NAS at home to sent automated system messages. These messages show in webmail but not in my IMAP client.
    When the NAS sents a mail the mail log reads this (anonymized):
    Code:
    Oct 18 09:03:16 mail postfix/smtpd[14899]: connect from sending.domain.com[xxx.xxx.xxx.xxx]
    Oct 18 09:03:16 mail postfix/smtpd[14899]: 85BFF40BA0: client=sending.domain.com[xxx.xxx.xxx.xxx]
    Oct 18 09:03:16 mail postfix/cleanup[14906]: 85BFF40BA0: message-id=<[email protected]>
    Oct 18 09:03:16 mail postfix/qmgr[14505]: 85BFF40BA0: from=<[email protected]>, size=1636, nrcpt=1 (queue active)
    Oct 18 09:03:16 mail postfix/smtpd[14899]: disconnect from sending.domain.com[xxx.xxx.xxx.xxx]
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) ESMTP::10024 /var/lib/amavis/tmp/amavis-20131018T090316-14341-ZXANHkgj: <[email protected]> -> <[email protected]> SIZE=1636 BODY=7BIT Received: from mail.sandb0x.nl ([127.0.0.1]) by localhost (mail.sandb0x.nl [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <[email protected]>; Fri, 18 Oct 2013 09:03:16 +0200 (CEST)
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) Checking: bkXPc56a2kPZ [xxx.xxx.xxx.xxx] <[email protected]> -> <[email protected]>
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) p001 1 Content-Type: text/plain, size: 316 B, name: 
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) wbl: whitelisted sender <[email protected]>
    Oct 18 09:03:16 mail postfix/smtpd[14912]: connect from localhost.localdomain[127.0.0.1]
    Oct 18 09:03:16 mail postfix/smtpd[14912]: B3BC140E44: client=localhost.localdomain[127.0.0.1]
    Oct 18 09:03:16 mail postfix/cleanup[14906]: B3BC140E44: message-id=<[email protected]>
    Oct 18 09:03:16 mail postfix/qmgr[14505]: B3BC140E44: from=<[email protected]>, size=2094, nrcpt=1 (queue active)
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) FWD from <[email protected]> -> <[email protected]>,BODY=7BIT 250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as B3BC140E44
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) Passed CLEAN {RelayedInbound}, [xxx.xxx.xxx.xxx]:12595 [xxx.xxx.xxx.xxx] <[email protected]> -> <[email protected]>, Queue-ID: 85BFF40BA0, Message-ID: <[email protected]>, mail_id: bkXPc56a2kPZ, Hits: -, size: 1636, queued_as: B3BC140E44, 236 ms
    Oct 18 09:03:16 mail postfix/smtp[14907]: 85BFF40BA0: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.39, delays=0.13/0.02/0.01/0.23, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as B3BC140E44)
    Oct 18 09:03:16 mail postfix/qmgr[14505]: 85BFF40BA0: removed
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) size: 1636, TIMING [total 249 ms] - sql-prepare: 5 (2%)2, SMTP greeting: 3 (1%)3, SMTP EHLO: 1 (0%)3, SMTP pre-MAIL: 1 (0%)4, mkdir tempdir: 5 (2%)6, create email.txt: 0 (0%)6, sql-connect: 10 (4%)10, lookup_sql: 2 (1%)11, SMTP pre-DATA-flush: 2 (1%)12, SMTP DATA: 17 (7%)19, check_init: 1 (0%)19, digest_hdr: 1 (0%)19, digest_body: 0 (0%)19, mkdir parts: 3 (1%)21, mime_decode: 8 (3%)24, get-file-type1: 41 (16%)40, parts_decode: 0 (0%)40, check_header: 2 (1%)41, AV-scan-1: 7 (3%)44, lookup_sql: 2 (1%)44, spam-wb-list: 1 (0%)45, decide_mail_destiny: 1 (0%)45, notif-quar: 0 (0%)45, fwd-connect: 29 (12%)57, fwd-mail-pip: 4 (2%)58, fwd-rcpt-pip: 0 (0%)59, fwd-data-chkpnt: 0 (0%)59, write-header: 1 (0%)59, fwd-data-contents: 0 (0%)59, fwd-end-chkpnt: 13 (5%)64, prepare-dsn: 1 (0%)64, main_log_entry: 78 (31%)96, update_snmp: 1 (1%)96, SMTP pre-response: 1 (0%)96, SMTP response: 8 (3%)100, unlink-1-files: 0 (0%)100, rundown: 1 (0%)100
    Oct 18 09:03:16 mail amavis[14341]: (14341-01) extra modules loaded: unicore/lib/Nt/De.pl, unicore/lib/Perl/SpacePer.pl
    Oct 18 09:03:16 mail dovecot: auth-worker(14915): mysql(localhost): Connected to database dbispconfig
    Oct 18 09:03:16 mail dovecot: lda([email protected]): sieve: msgid=<[email protected]>: stored mail into mailbox 'INBOX'
    Oct 18 09:03:16 mail postfix/pipe[14913]: B3BC140E44: to=<[email protected]>, relay=dovecot, delay=0.19, delays=0.01/0.02/0/0.15, dsn=2.0.0, status=sent (delivered via dovecot service)
    Oct 18 09:03:16 mail postfix/qmgr[14505]: B3BC140E44: removed
    Problem: in the second example the mail shows in my webmail but not in my IMAP client. These mails are marked with a 'delete' icon and are light grey. If I mark them as 'new' the DO show in my IMAP client.

    Any suggestions?
     

Share This Page