linux_vserver_debian_etch tutorial : can not create guests

Discussion in 'HOWTO-Related Questions' started by fortuitude, May 24, 2010.

  1. fortuitude

    fortuitude New Member

    Hello, everybody!

    I have followed the steps described on the tutorial of daniel15 about the set up of guests virtual machines. The tutoriel is about Etch, but I am running a lenny, with the 2.6.26 kernel. Both versions should be close enough to let me do such thinks.
    Everything is fine during the configuration of the host and I can reboot withour problem on my vserver kernel.

    When I try to create a vserver guest, through this command:
    newvserver --vsroot /var/lib/vservers --hostname test1 --domain genepi-9.local --ip --dist etch --mirror --interface eth1
    the output is like:
    VxID: 0
    I: Retrieving Release
    and then it hangs...
    I have tried other distributions (lenny for instance) with the same result.

    I have the following lines on /var/log/syslog
    May 24 11:59:15 genepi-9 kernel: [ 2195.646241] Not cloning cgroup for unused subsystem ns
    When I try to cancel the building of the guest (Ctrl+C) I get this
    chroot-sh: open("/etc/apt/sources.list"): No such file or directory
    chroot-sh: open("/etc/apt/apt.conf"): No such file or directory
    However these files exist where they are supposed to :-S

    Can anyone help me, finding out what's happening?

    Thanks :)
    Last edited: May 24, 2010

Share This Page