Linux doesnt speak spanish

Discussion in 'Installation/Configuration' started by paul sanz, Oct 2, 2007.

  1. paul sanz

    paul sanz New Member

    Hi and good morning fellow Forge´s

    Im paul and im working in madrid spain. I have config it to spanish on installation and im getting all different kind of caracter messups likes; :confused:

    -Público *this should read Publico

    -Imágenes * this should read Imagines

    Why is this? as you may understand it serious for example when writing scripts and looking up files and directories when automating a task i get errors because the system doesnt find the files i need as the caractering is all messup.

    Can someone give me a push in the right direccion and how i can fix this problem.



    Linux logos #1 SMP Fri Jul 27 18:21:43 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Where do you get the wrong characters? On the shell, in ISPConfig or in a website?
  3. paul sanz

    paul sanz New Member


    On the shell

    can you help?

    cheers in advance

  4. falko

    falko Super Moderator ISPConfig Developer

    You could try
    dpkg-reconfigure locales
  5. paul sanz

    paul sanz New Member

    hey falko hows it going :)

    I think dpkg-reconfigure locales is a debian thing, im using fedora 7.

    My current situation:

    Tried the following and still doesnt work

    LANG="[email protected]"

    #parameters that i dont change


    I can create new dir and edit file names with á é í ó ú and it writes it correctly but files and directories created by the system in the instalation still doesnt read those special characters correctly why??


    1. what is a keymap (load key) used for? and can it help me

    2. Can I combine the following font (i18n) options::confused:

    If yes which is the best combination?
    If not why?

    # LANG= set locale for all categories, can be any two letter ISO language code.
    # LC_CTYPE= localedata configuration for classification and conversion of characters.
    # LC_COLLATE= localedata configuration for collation (sort order) of strings.
    # LC_MESSAGES= localedata configuration for translation of yes and no messages.
    # LC_NUMERIC= localedata configuration for non-monetary numeric data.
    # LC_MONETARY= localedata configuration for monetary data.
    # LC_TIME= localedata configuration for date and time.
    # LC_ALL= localedata configuration overriding all of the above.
    # LANGUAGE= can be a : separated list of ISO language codes.
    # LINGUAS= can be a ' ' separated list of ISO language codes.
    # SYSFONT= any font that is legal when used as /usr/bin/consolechars -f $SYSFONT ... (See console-tools package for consolechars command)
    # UNIMAP= any SFM (screen font map, formerly called Unicode mapping table - see consolechars(8))

    3. Can i edit the /etc/profile.d/ to force the LANG="" instead of looking for it in the i18n file?


Share This Page