Limit PHP versions seen by client.

Discussion in 'General' started by iDen, Aug 26, 2014.

  1. iDen

    iDen New Member

    System has 2 compiled PHP versions.
    Default 5.4.32 for fcgid and mod_php.
    And 5.4.32 compiled with PHP-FPM support, which should be default for 99.999999% of users.

    Creating user and allowing him to have only "Disabled" and "PHP-FPM" PHP modes.
    Then creating "Site" within this client and choosing only active php mode out of two, "PHP-FPM", ISPconfig in PHP versions below shows me two options:

    And just for experiment creating website with "Default" php version while having php-fpm mode - throws no errors.
    How? Why? I'm not giving user ability to have site running mod_php or fastcgi.
    As I understood it is just hardcoded piece of code.

    I would like to make kind of request regarding this "issue".
    It would be nice to change "Default" php version for client let's say It will be linked to php_54_fpm in my case.
    Or better aproach might be restrict visible PHP versions through Client Limits templates (Main/Additional) ?

Share This Page