lighttpd with fastcgi on centos

Discussion in 'Server Operation' started by bluethundr, Aug 27, 2012.

  1. bluethundr

    bluethundr New Member

    Hello,

    I am trying to setup lighttpd with fastcgi on centos 6.3 using this howto:

    http://www.howtoforge.com/installing-lighttpd-with-php5-and-mysql-support-on-centos-5.6

    I'm not positive of any differences in setting this up under 6.3 vs 5.6 but I am giving it a shot.

    I'm using lighttpd 1.4.31 on a centos 6.3 box:
    Code:
    [root@centos:/etc/lighttpd] #lighttpd -v
    lighttpd/1.4.31 (ssl) - a light and fast webserver
    Build-Date: Jun  6 2012 13:26:00
    
    [root@centos:/etc/lighttpd] #cat /etc/redhat-release 
    CentOS release 6.3 (Final)
    
    And the only changes I made to get fastcgi working are as follows. in php.ini

    Code:
    cgi.fix_pathinfo = 1
    
    In modules.conf I have:
    Code:
    ## FastCGI (mod_fastcgi)
    ##
    include "conf.d/fastcgi.conf"
    
    In conf.d/fastcgi.conf I have:
    Code:
    fastcgi.server = ( ".php" =>
                       ( "php-local" =>
                         (
                           "socket" =>  "/tmp/php-fastcgi.socket",
                          "bin-path" => "/usr/bin/php-cgi",
                           "max-procs" => 1,
                           "broken-scriptfilename" => "enable",
                         )
                       ),
                      ( "php-tcp" =>
                         (
                           "host" => "xx.xx.xx.xx",
                          "port" => 9999,
                           "check-local" => "disable",
                           "broken-scriptfilename" => "enable",
                         )
                       ),
    
                       ( "php-num-procs" =>
                         (
                           "socket" =>  "/tmp/php-fastcgi.socket",
                           "bin-path" => "/usr/bin/php-cgi",
                           "bin-environment" => (
                             "PHP_FCGI_CHILDREN" => "16",
                             "PHP_FCGI_MAX_REQUESTS" => "10000",
                           ),
                           "max-procs" => 5,
                           "broken-scriptfilename" => "enable",
                         )
                       ),
                    )
    
    I then restart the lighttpd server and it comes back up again just fine. But the phpinfo page that I created white screens.

    But the php info page works on the command line
    Code:
    [root@centos:/var/www/lighttpd] #php phpinfo.php 
    <?
      phpinfo();
    ?>
    
    Can I please get some tips on how to troubleshoot and solve this problem?

    Thanks
     
    Last edited: Aug 27, 2012
  2. falko

    falko Super Moderator ISPConfig Developer

Share This Page