Lighttpd failing to install

Discussion in 'Installation/Configuration' started by ayw, Jun 10, 2012.

  1. ayw

    ayw New Member

    I'm fairly new to the whole VPS thing and hardly know what I'm doing, however I've been following all kinds of tutorials all over the place and keep getting the same issue time and time again.

    This is what I'm trying to acheive:

    This is what I'm getting at the first hurdle:
    sudo apt-get install lighttpd
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     lighttpd : Depends: libterm-readline-perl-perl but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    I'm on a VPS running Ubuntu LTS 12.04 - the provider automatically installs Apache, PHP, MySql etc, but I removed them first but still had the above issue.

    I've tried a conundrum of things, all mainly shots in the dark.

    Any help would be very much appreciated.
  2. rosehosting

    rosehosting Member

    Can you try running:

    apt-get clean && apt-get autoclean
    followed by

    apt-get update && apt-get upgrade --show-upgraded
    then try to re-run the installation of lighthttp. If that is still not working, then please post the sources you're using.

    Also, I would personally go and install libterm-readline-perl-perl manually and proceed with the installation.
  3. ayw

    ayw New Member

Share This Page