lighttpd and virtual host

Discussion in 'Server Operation' started by aberrio, Dec 4, 2008.

  1. aberrio

    aberrio New Member


    I tried to follow this how to..., on opensuse 11.0 but having problems.

    iI belive my issues is in the mysql_vhost.pyfile.

    When I tried to test the vhost with /usr/share/lighttpd/ lighttpd lighttpd secret I am getting this error..

    : No such file or directory

    How can I change this statement to be compatible with openSUSE 11.0...

    print "$HTTP[\"host\"] == \"%s\" {\nserver.document-root = \"%s\"\n%s\n}" % (domain[0], domain[1], domain[2])..?


  2. aberrio

    aberrio New Member

    any update with this?
  3. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    which env
  4. aberrio

    aberrio New Member

    Thx Falko I fix the issue, server need to be restared after add a new domain, is this something that I have to do?
  5. falko

    falko Super Moderator ISPConfig Developer

    That's strange. Are there any errors in your logs? Did you disable AppArmor?

Share This Page