lighttp failed to install

Discussion in 'Installation/Configuration' started by White, Sep 2, 2009.

  1. White

    White New Member

    Hi Falko,

    ive done the perfect lenny setup and proftp and virtual users with mysql and everything is fine.

    Now i wanted to install eAccelerator which requires lighttpd and i was following Install PHP 5.3.0/Lighttpd On Debian (Lenny) With Imap, MySQL, Sqlite3 And ImageMagick Support

    the first statement is aptitude install lighttpd thats when i hit my first error

    the output from the shell was this

    so i tried stopping apache2 and got the following

    i dont have the knowledge base yet to know what this means can you help please

    Apache2 wouldnt restart so i had to remove lighttpd
    see below

    All of my sites have now died and return a blank page

    netstat -lnp | grep :::80 returns
    tcp6 0 0 :::80 :::* LISTEN 4912/apache2
    but its not firing up my sites, default and defaul-ssl are fine nothing has ben changed in there
    Last edited: Sep 2, 2009
  2. White

    White New Member

    Ive totally fluffed things up, tried to uninstall apache2 and reinstall it, now dpkg is returning errors.

    1 not fully installed or removed.
    After this operation, 0B of additional disk space will be used.
    Setting up libapache2-mod-fcgid (1:2.2-1) ...
    Could not create /etc/apache2/mods-enabled/fcgid.conf: No such file or directory
    dpkg: error processing libapache2-mod-fcgid (--configure):
    subprocess post-installation script returned error exit status 2
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    Apache2 isnt installed properly shed loads of directories are missing, can you tell me how to uninstall apache2 and php5 all the modules for both as loaded from the perfect setup then i can re-install them from the setup again
  3. White

    White New Member

    I put back all my old apache2 dir's and purged lighttpd, i can access as this seems to be working and is located in /var/www/mydomain/index.html

    my sites enabled points to doc route /var/www/mydomain

    however all my other sites are located in /etc/home and are php files

    i placed a index.html into each site and they return in the browser, thus i can deduce that there is a php issue as it isnt returning any php site
  4. falko

    falko Super Moderator ISPConfig Developer

  5. White

    White New Member

    Problem Solved !!

    Thanks Falko, i did a rebuild on my server today from the ground up.

    everything was fine until i installed eAccelerator as per the how to then the blank pages came back and various errors to do with segmentation again. But this time i noticed that one error had a conflict between eAccelerator and Xcache so i moved Xcache from the conf.d folder, restarted apache2, this did nothing.

    I had a look at another php.ini file in conf.d and noticed that the
    in the eaccelerator.ini file had "" around the .so but all my other .ini files didnt so i removed them,
    restarted apache2 hey presto my php sites came back. i put Xcache back in conf.d as a test restarted apache2 and again they returned blank pages so i undid that operation now everything is fine.

    Hoping this may help someone else.

Share This Page