libming0 + etch

Discussion in 'Installation/Configuration' started by planet_fox, Apr 16, 2007.

  1. planet_fox

    planet_fox Member

    I have dist -upgrade from sarge to etch its finish. and this was after the upgrade my problem

    Code:
    server:/# apt-get upgrade
    Reading package lists... Done
    Building dependency tree... Done
    You might want to run `apt-get -f install' to correct these.
    The following packages have unmet dependencies:
      php4-ming: Depends: libming0 but it is not installed
    E: Unmet dependencies. Try using -f.
    I do apt-get -f install

    Code:
    server/# apt-get -f install
    Reading package lists... Done
    Building dependency tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      libming0
    The following NEW packages will be installed:
      libming0
    0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
    1 not fully installed or removed.
    Need to get 0B/164kB of archives.
    After unpacking 393kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    
    Reading package lists... Done
    Building dependency tree... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      libming0
    The following NEW packages will be installed:
      libming0
    0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
    1 not fully installed or removed.
    Need to get 0B/164kB of archives.
    After unpacking 393kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    debconf: unable to initialize frontend: Kde
    debconf: (Unable to load Qt -- is libqt-perl installed?)
    debconf: falling back to frontend: Dialog
    (Reading database ... 51250 files and directories currently installed.)
    Unpacking libming0 (from .../libming0_1%3a0.3.0-11_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libming0_1%3a0.3.0-11_i386.deb (--unpack):
     trying to overwrite `/usr/lib/libming.so.0', which is also in package libming
    Errors were encountered while processing:
     /var/cache/apt/archives/libming0_1%3a0.3.0-11_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    
     
  2. Hans

    Hans Moderator ISPConfig Developer

    I would try the command:
    aptitude -f --with-recommends dist-upgrade

    Aptitute has better control over dependencies then apt.
    With the command above, i think you're able to fix the problem.
    (You can still use this command after your upgrade to Etch).

    Good luck!
     
  3. planet_fox

    planet_fox Member

    ok see here

    Code:
    server:/home/user# aptitude -f --with-recommends dist-upgrade
    Reading package lists... Done
    Building dependency tree... Done
    Reading extended state information
    Initializing package states... Done
    Reading task descriptions... Done
    Building tag database... Done
    The following packages are BROKEN:
      libapache2-mod-php5 libgssapi1-heimdal
    The following NEW packages will be automatically installed:
      libroken16-heimdal
    The following packages will be automatically REMOVED:
      libroken16-kerberos4kth
    The following NEW packages will be installed:
      apache2-mpm-prefork libming0 libroken16-heimdal
    The following packages will be REMOVED:
      apache2-mpm-worker libroken16-kerberos4kth
    The following packages will be upgraded:
      libkrb5-17-heimdal php5-ming
    2 packages upgraded, 4 newly installed, 2 to remove and 0 not upgraded.
    Need to get 222kB/3291kB of archives. After unpacking 5882kB will be used.
    The following packages have unmet dependencies:
      libgssapi1-heimdal: Depends: libroken16-kerberos4kth (>= 1.2.2-11.2) but it is not installable
      libapache2-mod-php5: Depends: php5-common (= 5.2.0-8+etch1) but 5.2.1-0.dotdeb.1 is installed.
    Resolving dependencies...
    The following actions will resolve these dependencies:
    
    Keep the following packages at their current version:
    libapache2-mod-php5 [Not Installed]
    libkrb5-17-heimdal [0.6.3-10sarge2 (now)]
    libroken16-heimdal [Not Installed]
    libroken16-kerberos4kth [1.2.2-11.2 (now)]
    php5-ming [5.2.1-0.dotdeb.1 (now)]
    
    Score is -19
    
    Accept this solution? [Y/n/q/?]
    
    I don't want this apache2-mpm-prefork do on my server runs apache-worker

    andwhen I say yes, this came

    Code:
    The following packages have been kept back:
      libkrb5-17-heimdal php5-ming
    The following NEW packages will be installed:
      apache2-mpm-prefork libming0
    [COLOR="Red"]The following packages will be REMOVED:
      apache2-mpm-worker[/COLOR]
    0 packages upgraded, 2 newly installed, 1 to remove and 2 not upgraded.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I think the problem is that you have PHP installed as a module, and the module works with apache2-mpm-prefork, but not with apache2-mpm-worker.
     
  5. planet_fox

    planet_fox Member

    How can do ? remove php5 ?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You can remove the PHP module and install PHP as CGI.
     

Share This Page