lex is insufficient to compile libpcap

Discussion in 'HOWTO-Related Questions' started by BruceWilkinson, Dec 18, 2006.

  1. BruceWilkinson

    BruceWilkinson New Member

    I'm working through Intrusion Detection With BASE And Snort tutorial (http://www.howtoforge.com/intrusion_detection_base_snort_p3) on Ubuntu. I ran into a problem at make/install LIBPCAP (page 3). When I execute ./configure, I get the following error:

    configure: error: Your operating system's lex is insufficient to compile
    libpcap. flex is a lex replacement that has many advantages, including
    being able to compile libpcap. For more information, see

    I'm familiar with Linux and Ubuntu, but not knowlegeable enough to know how to resolve this problem.

    Can anyone help?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    apt-get install flex

    to install the latest flex version.
  3. BruceWilkinson

    BruceWilkinson New Member

    Thanks Till, that did the trick.

Share This Page