Letsencrypt - Wrong symlinks (filename)

Discussion in 'Installation/Configuration' started by Lars1973, Mar 26, 2019.

  1. Lars1973

    Lars1973 New Member


    I'm running ISPConfig 3.1.13 p1 with Apache 2.4.25 on Debian Stretch and have the following issue:

    Generation of the LE certificate and key work fine, but the vhost has wrong filenames in the configuration file.

    Filenames in vhost (without "-le" extension)
    SSLCertificateFile /var/www/clients/clientXX/webXX/ssl/example.net.crt
    SSLCertificateKeyFile /var/www/clients/clientXX/webXX/ssl/example.net.key
    SSLCACertificateFile /var/www/clients/clientXX/webXX/ssl/example.net.bundle

    BUT the symlinks have the extension "-le" added to the filenames (i.e. "$domain-le" instead of "$domain" only):
    lrwxrwxrwx 1 root root 42 Mar 26 00:49 example.net-le.bundle -> /etc/letsencrypt/live/example.net/chain.pem
    lrwxrwxrwx 1 root root 46 Mar 26 00:49 example.net-le.crt -> /etc/letsencrypt/live/example.net/fullchain.pem
    lrwxrwxrwx 1 root root 44 Mar 26 00:49 example.net-le.key -> /etc/letsencrypt/live/example.net/privkey.pem

    Any idea how to fix this issue ?

    Thanks !
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely you created an SSL cert on the SSL tab of the website. Remove that ssl cert on the ssl tab of the site by using the delete certificate option there.
  3. Lars1973

    Lars1973 New Member

    I only checked the "SSL" and "Let's Encrypt SSL" on the Domain tab.

    Just tried it with another domain name - same problem:
    apache vhost conf: domain.com.crt
    sym link: domain.com-le.crt

    The path is fine - but the filename is different...
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a guess, you are using a custom vhost template? If yes, then you missed adjusting your custom vhost template to be compatible with the current ISPConfig version.

Share This Page