LetsEncrypt Webmail not found - Perfect Debian 8+Apache

Discussion in 'Installation/Configuration' started by Petar, Sep 12, 2017.

  1. Petar

    Petar New Member

    Installed: Perfect Server Debian 8 + Apache, ISP Config Latest 3.1.6
    https://www.howtoforge.com/tutorial...8-4-jessie-apache-bind-dovecot-ispconfig-3-1/

    Without LE all the lynks are working: the website, the phpmyadmin, the webmail...

    After enabling LetsEncrypt for any of the domains:
    https://domain.com = opens OK with green lock
    https://domain.com/phpmyadmin = opens OK with green lock
    https://domain.com/webmail = opens Error Not Found ISPc 404 page, (in logs: GET /webmail HTTP/1.1" 404 2230)

    What should be added or changed for the webmail symlink to work under https ?
     
  2. HSorgYves

    HSorgYves Member HowtoForge Supporter

    Are you sure /webmail is working on HTTP? I guess you installed roundcube. Try changing the Link to /roundcube
     
  3. Petar

    Petar New Member

    @As mentioned: Without LE all the links are working: the website, the phpmyadmin, the webmail...
    so, http://domain.com/webmail works perfectly without LE.
    Only after installing LE, for the webmail/roundcube the link is 404,
    but not the link for phpmyadmin, https://domain.com/phpmyadmin works perfectly, so there must be some error in the symlink?
    I tried several times on different VMs of the same type...
     
  4. HSorgYves

    HSorgYves Member HowtoForge Supporter

    My roundcube works perfectly well with HTTPS, installed using the Debian 9 tutorial though... why are you using Debian 8 on a fresh install?
     
  5. Petar

    Petar New Member

    Tried the 9 with nginx, but i had several more problems during the use of ISPc and the whole new system, so i'm still using for production the 8+ap and testing the 9+ap/ng until filling comfortable
     
  6. Petar

    Petar New Member

  7. HSorgYves

    HSorgYves Member HowtoForge Supporter

    That problem is not similar, his would not have been working under http either, he simply didn't have enabled the webmail. Besides he was using squirrelmail, however you are using roundcube. Try to access the robots.txt file of roundcube under http and https:
    http(s)://domain.com/webmail/robots.txt
     

Share This Page