Letsencrypt SSL works but only without organization info

Discussion in 'ISPConfig 3 Priority Support' started by itsolon, Mar 5, 2018.

  1. itsolon

    itsolon Member

    My Server delivers the website .. sometimes even with ssl cert but without information of issuer
    please have a look on the png
    where do i put the information for that?
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Let's encrypt provides domain based SSL certs. If you need an extended validation SSL cert, then you will have to purchase that from one of the knows SSL authorities, disable letsencrypt for that website and add the extended validation ssl cert on the ssl tab of the website.
     
  3. itsolon

    itsolon Member

    Thank you for that info, i misunderstood why browers say not valid..
    all letsencrypt certs are domain based not organization ones..
    but the reason why i thought is: the server delivered standard ssl instead of domain issued letsencrypt

    perhap i tried to much things like delete cert with delete tab from website configuration

    ok.

    now i have deleted manually .. unfortunately i deleted following
    /etc/letsencrypt/live/bellabeauty.de/ and certs inside and all symlinks into virtual host
    /var/www/bellabeauty.de/ssl is empty too

    and server made

    /etc/letsencrypt/live/bellabeauty.de-0001 as i tried again
    but now the server makes no symlinks anymore and ssl can not be issued anymore

    only this one is left
    lrwxrwxrwx 1 root root 43 Mar 5 12:35 cert.pem -> ../../archive/bellabeauty.de-0001/cert1.pem
    lrwxrwxrwx 1 root root 44 Mar 5 12:35 chain.pem -> ../../archive/bellabeauty.de-0001/chain1.pem
    lrwxrwxrwx 1 root root 48 Mar 5 12:35 fullchain.pem -> ../../archive/bellabeauty.de-0001/fullchain1.pem
    lrwxrwxrwx 1 root root 46 Mar 5 12:35 privkey.pem -> ../../archive/bellabeauty.de-0001/privkey1.pem
    -rw-r--r-- 1 root root 543 Mar 5 12:35 README
    [email protected]:/etc/letsencrypt/live/bellabeauty.de-0001#

    QUESTION:
    Can i repair that manually as i broke it manually?
    - repair path to bellabeauty.de
    - issue new cert
    - wait for server to make symlinks from live to ssl
    - understand what archive has to do with that all (thats unclear for me)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to ispconfig, disable letsencrypt in the settings of that site, save, edit the site again and enable letsencrypt again for that site and save.
     
  5. itsolon

    itsolon Member

    is solved Thank you very much. I had to wait for a few seconds and not click so fast :) the issueing process needs time.
    Sometimes it can help if issuer ran into an limit at letsencrypt
    you can check this here:
    https://letsencrypt.org/docs/rate-limits/
    https://crt.sh/
    here you can search for your cert. and see how often you issued
    they have a time frame .. sometimes it can be neccessary to wait a day or two.
    best regards Markus
     

Share This Page