Letsencrypt SSL bug in ISPC 3.1.4 -le wrongly added to certificate files

Discussion in 'ISPConfig 3 Priority Support' started by medo, Jun 24, 2017.

  1. medo

    medo Member HowtoForge Supporter

    Hi,

    I updated my multiserver ISPC to latest version and Letsencrypt is bugging.
    When I generate a new certificate, a wrong link is generated in /var/www/mywebsite.com/ssl, it is name mywebsite.com-le.key and mywebsite.com-le.crt, or it is named in nginx vhost config file mywebsite.com.key and mywebsite.com.crt, so -le is wrongly added, can you confirm ?

    Thank you.
     
  2. medo

    medo Member HowtoForge Supporter

    Problem occurs on nginx ispc, not apache. File has -le but seems to work.
    It also took me two times to make it work, the first time, the ssl files were generated but no link to them created in /ssl...
     
  3. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    May it be that you have a custom nginx vhost config file inside /usr/local/ispconfig/server/conf-custom ?
     
  4. medo

    medo Member HowtoForge Supporter

    Thanks for the answer, but no, I do not use conf-custom
     
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The name of the cert link files have been changed in one of the previous versions so it is correct that an -le is appended. Please check the vhost file if there are also -le files mentioned as it might be that only some entries were missed during update of the code.
     

Share This Page