LetsEncrypt on a second server

Discussion in 'Installation/Configuration' started by ewkilian, Sep 27, 2019.

  1. ewkilian

    ewkilian New Member

    Hi,
    I have a server with "domain.com" integret the certificat for "domain.com"
    And now I have a second server "mail.domain.com" (different public ip).
    And I try to generate a certificat lets encrypt for mail.domain.com,
    But I have this error :
    b'{\n "identifier": {\n "type": "dns",\n "value": "mail.domain.com"\n },\n "status": "invalid",\n "expires": "2019-10-04T13:19:03Z",\n "challenges": [\n {\n "typ$
    2019-09-27 15:19:07,851:DEBUG:acme.challenges:tls-alpn-01 was not recognized, full message: {'type': 'tls-alpn-01', 'status': 'invalid', 'url': 'https://acme-v02.api.letsencrypt.org/acme/chall$
    2019-09-27 15:19:07,851:DEBUG:acme.client:Sending GET request to https://acme-v02.api.letsencrypt.org/acme/authz-v3/526510191.
    2019-09-27 15:19:09,021:DEBUG:urllib3.connectionpool:https://acme-v02.api.letsencrypt.org:443 "GET /acme/authz-v3/526510191 HTTP/1.1" 200 1529
    2019-09-27 15:19:09,022:DEBUG:acme.client:Received response:
    HTTP 200
    Server: nginx
    Date: Fri, 27 Sep 2019 13:19:08 GMT
    Content-Type: application/json
    Content-Length: 1529
    Connection: keep-alive
    Cache-Control: public, max-age=0, no-cache
    Link: <https://acme-v02.api.letsencrypt.org/directory>;rel="index"
    X-Frame-Options: DENY
    Strict-Transport-Security: max-age=604800


    Can you help me, or explain me ?
    thank you.
    Ewkilian
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. ewkilian

    ewkilian New Member

    Hi,
    Yes mail.domain.com, is OK, when I try DNS Lookup, the IP is correct.
    For generate this certificat, I check SSL and Lets Encrypt and Valid.
    when I return the 2 checkbox is unselect.
    Have you a idea ? do you want more information to determine the reason ?
    thank you.
    EwKilian
     

Share This Page