letsencrypt error

Discussion in 'ISPConfig 3 Priority Support' started by Tom John, Nov 29, 2020.

  1. Tom John

    Tom John Member HowtoForge Supporter

    Hi guys,

    i am using ubuntu20.04 with ISPconfig 3
    I just migrated one server to another with ISPConfig migration tool.
    When enable in ISPConfig administration SSL Cert for a domain neue-welten.teneriffa-akupunktur.com the certificate is not renewing when i activate on webdomain SSL and Letsencrypt SSL after check it it disappears again.
    in the logfiles i get the following error:
    Code:
    2020-11-29 18:40:04,992:DEBUG:certbot.main:certbot version: 0.40.0
    2020-11-29 18:40:04,992:DEBUG:certbot.main:Arguments: ['-n', '--text', '--agree-tos', '--expand', '--authenticator', 'webroot', '--server', 'https://acme-v02.api.letsencrypt.org/directory', '--rsa-key-size', '4096', '--email', '[email protected]', '--domains', 'neue-welten.teneriffa-akupunktur.com', '--domains', 'www.neue-welten.teneriffa-akupunktur.com', '--webroot-path', '/usr/local/ispconfig/interface/acme']
    2020-11-29 18:40:04,993:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
    2020-11-29 18:40:05,013:DEBUG:certbot.log:Root logging level set at 20
    2020-11-29 18:40:05,013:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
    2020-11-29 18:40:05,015:DEBUG:certbot.plugins.selection:Requested authenticator webroot and installer None
    2020-11-29 18:40:05,016:DEBUG:certbot.plugins.selection:Single candidate plugin: * webroot
    Description: Place files in webroot directory
    Interfaces: IAuthenticator, IPlugin
    Entry point: webroot = certbot.plugins.webroot:Authenticator
    Initialized: <certbot.plugins.webroot.Authenticator object at 0x7f64a01feca0>
    Prep: True
    2020-11-29 18:40:05,017:DEBUG:certbot.plugins.selection:Selected authenticator <certbot.plugins.webroot.Authenticator object at 0x7f64a01feca0> and installer None
    2020-11-29 18:40:05,017:INFO:certbot.plugins.selection:Plugins selected: Authenticator webroot, Installer None
    2020-11-29 18:40:05,037:DEBUG:certbot.log:Exiting abnormally:
    Traceback (most recent call last):
      File "/bin/letsencrypt", line 11, in <module>
        load_entry_point('certbot==0.40.0', 'console_scripts', 'certbot')()
      File "/usr/lib/python3/dist-packages/certbot/main.py", line 1382, in main
        return config.func(config, plugins)
      File "/usr/lib/python3/dist-packages/certbot/main.py", line 1249, in certonly
        le_client = _init_le_client(config, auth, installer)
      File "/usr/lib/python3/dist-packages/certbot/main.py", line 607, in _init_le_client
        acc, acme = _determine_account(config)
      File "/usr/lib/python3/dist-packages/certbot/main.py", line 515, in _determine_account
        acc = display_ops.choose_account(accounts)
      File "/usr/lib/python3/dist-packages/certbot/display/ops.py", line 84, in choose_account
        code, index = z_util(interfaces.IDisplay).menu(
      File "/usr/lib/python3/dist-packages/certbot/display/util.py", line 503, in menu
        self._interaction_fail(message, cli_flag, "Choices: " + repr(choices))
      File "/usr/lib/python3/dist-packages/certbot/display/util.py", line 466, in _interaction_fail
        raise errors.MissingCommandlineFlag(msg)
    certbot.errors.MissingCommandlineFlag: Missing command line flag or config entry for this setting:
    Please choose an account
    Choices: ['[email protected]:36:15Z (e140)', '[email protected]:39:30Z (d78d)']
    2020-11-29 18:40:05,710:DEBUG:certbot.main:certbot version: 0.40.0
    2020-11-29 18:40:05,711:DEBUG:certbot.main:Arguments: ['--domains', 'neue-welten.teneriffa-akupunktur.com', '--domains', 'www.neue-welten.teneriffa-akupunktur.com']
    2020-11-29 18:40:05,711:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
    2020-11-29 18:40:05,725:DEBUG:certbot.log:Root logging level set at 20
    2020-11-29 18:40:05,726:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
    2020-11-29 18:40:05,787:WARNING:certbot.cert_manager:Renewal configuration file /etc/letsencrypt/renewal/mask1001.com.conf produced an unexpected error: renewal config file {} is missing a required file reference. Skipping.
    2020-11-29 18:40:05,790:DEBUG:certbot.cert_manager:Traceback was:
    Traceback (most recent call last):
      File "/usr/lib/python3/dist-packages/certbot/cert_manager.py", line 79, in certificates
        renewal_candidate = storage.RenewableCert(renewal_file, config)
      File "/usr/lib/python3/dist-packages/certbot/storage.py", line 444, in __init__
        raise errors.CertStorageError(
    certbot.errors.CertStorageError: renewal config file {} is missing a required file reference
    
    
    as i see : /etc/letsencrypt/renewal/mask1001.com.conf produced an unexpected error:
    is it possible to delete mask1001.com.conf to solve the problem?
    I think when i migrate one server to another i did migrate some ssl certificates i not need anymore.
    so when i do ls /etc/letsencrypt/renewal i get:
    Code:
    [email protected]:~# ls /etc/letsencrypt/renewal
    
    server1.cl-i.net.conf
    server2.cl-i.net.conf
    server4.cl-i.net.conf
    
    
    
    i think this certificates i took from one server to another server so if my actual server is server4 can i delete as well server1.cl-i.net.conf and server2.cl-i.net.conf?

    thanks a lot for your help guys
     
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Remove your old LE account from /etc/letsencrypt/accounts/acme-v02.api.letsencrypt.org
     
  3. Tom John

    Tom John Member HowtoForge Supporter

    It works!
    thanks a lot for your quick and good help as always.
     
    till and Th0m like this.

Share This Page