LetsEncrypt: Domain name change

Discussion in 'Installation/Configuration' started by zbuzanic, Jun 3, 2019.

  1. zbuzanic

    zbuzanic Member

    Hi,
    I created website "website.something.com" then changed it to "website.new.com" and everything is working OK except LetsEncrypt cert is still for old domain name.

    How to fix cert or regenerate it without messing too much?
    Thank you in advance,
    Zvonimir
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    On website settings, turn off LE. Wait 2 minutes. Turn LE back on.
     
  3. zbuzanic

    zbuzanic Member

    Already tried this, still using old cert. I'll disable LE completely for some time to see if that helps...
     
  4. ahrasis

    ahrasis Well-Known Member

    Try updating to git-stable.
     
  5. zbuzanic

    zbuzanic Member

    Well, now I cannot edit anything in , logged as admin, I have MySQL 8...
    Code:
    Access denied; you need (at least one of) the SUPER, SYSTEM_VARIABLES_ADMIN or SESSION_VARIABLES_ADMIN privilege(s) for this operation
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  7. zbuzanic

    zbuzanic Member

    So, the system is CentOS 7.6, httpd, mysql 8,, php 7.1
    ISPConfig is git-stable
    Seems like some permission is missing, I can login into control panel, but can't edit with admin or any other admin, I did look into tables but not sure what to change to allow editing system values. Will try to look at sql updates...
    https://buzanic.com/error/htf_report.txt
     
    Last edited: Jun 5, 2019
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    MySQL 8 is not supported by ISPConfig yet. MySQL 8 is not completely downwards compatible to older MySQL version or MariaDB, so ISPConfig will not work on it until we release a version for MySQL 8. Please read the ISPConfig installation tutorials (perfect server guides) to install your system properly for ISPConfig.
     
  9. zbuzanic

    zbuzanic Member

    Ok, good to know, anyway I've fixed this by giving right permission to ispconfig user in mysql database.
     

Share This Page