LetsEncrpyt and Ispconfig issue

Discussion in 'Installation/Configuration' started by mislav, Jun 6, 2019.

  1. mislav

    mislav Member

    - Linux Distribution and version used on your server: Debian 7
    - ISPConfig version: 3.1.13p1

    Here is the description of the problem I've noticed: for some strange reason ISPConfig creates SSL certificate and symlinks in /var/www/website.TLD/ssl folder and everything inside that folder, together with letsencrypt is created properly - although there are missing checkboxes inside ispconfig for SSL/Letsencpryt and thus, vhost file in sites-available/enabled is not created - I suspect it could be because autosubdomain was configured to ".*", instead of just "www" - but that's not the problem.

    First problem is why ispconfig requested SSL from letsencrypt, but didn't create proper vhost file in apache configured? I would understand that error occurred with domain itself, e.g. it's pointing somewhere else - when letsencrypt fails = apache vhost file creation fails. But why it created one part, but other part it didn't?

    Next problem: I fix autosubdomain to www, remove certificate with "certbot delete" and symlinks....everything - CLEAN start, correct? We're back to zero, nothing is created, everything is properly. Now comes the next problem - I select again SSL/letsencrypt in ispconfig for the website I closely watch the letsencrypt.log file what happens and ispconfig did everything correctly from the lets encrypt side, however, first of all it didn't create anything in /var/www/website.TLD/ssl, secondly, checboxes were missing in ispconfig and last, but not least, no changes are made in apache vhost file for domain name.

    In order to use SSL cert, I have to manually create symlinks and manually configure virtualhost 443 part with entries - which is not a problem, this works well after apache restart and website works on https when request. However, me/client must be aware that for that domain, they are not allowed anymore to do any changes there, because the file will get overwritten.

    How to debug this situation/why is this happening. Let me know and I will debug! Thanks
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    Run ispconfig_update.sh and choose git-stable, then uncheck both ssl and letsencrypt checkboxes for the domain, wait 2 minutes and enable them again.
     
  3. mislav

    mislav Member

    Hello @Jesse Norell
    Thank you very much - this did the trick and it's working! Do you know maybe what was the issue?
     
  4. manoaratefy

    manoaratefy New Member

    Refering to this post:
     

Share This Page