Lets encrypt working only for domain, not ISPConfig

Discussion in 'Installation/Configuration' started by pecka33, Feb 14, 2022.

  1. pecka33

    pecka33 Member


    am using latest debian and ispconfig and trying to set SSL lets encrypt to ispconfig locate on ipaddress:8080. But i can not found how can i do it. I tried a lot of changes, reupdate ispconfig, obtatin ssl for ispconfig again etc.But nothing work for me.
    So i tried to add new alias which has hostname of my server - host.domain.com. I add this as alias to my domain with lets encrypt - domain.com
    When i access to url host.domain.com:8080, host.domain.com/webmail etc i can see secure with lets encrypt, but when i tried to access ipaddress:8080, ipaddress/webmail etc. i can see there still self signed ssl.

    Any idea how can i solved it?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    With IP-address in URL the certificate can never match, since it certifies the FQDN matches. IP-address is always different from the hostname.
    If you get the green padlock in browser address bar and browser stops warning about insecure connection, you certificate and setup is as it should be.
    ahrasis and Th0m like this.
  3. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    This is how it should be and there is nothing to be solved. LE certs are only issued for domain name.

Share This Page