Lets encrypt - WARNING - Falsche Anfrage / Wrong QuerySQL-Query

Discussion in 'General' started by spazio, Dec 16, 2017.

  1. spazio

    spazio Member

    Hi all!

    My multiserver setup is having some problems with one of the slave on letsencrypt certificate!
    The config is:
    master debian 8 ispconfig 3.1.9 - public IP
    slave1 debian 8 ispconfig 3.1.9 - This server is on a private IP with NAT on a router with a public IP - All the server ports are nated from the public IP

    It.s been working perfectly since last year. I was able to create certificate for multiples web site on slave1. And they all renewed without problems. Today I needed to add one ssl certificate and here is what I got in the debug log:
    tail /var/log/ispconfig/ispconfig.log

    15.12.2017-17:09 - WARNING - Falsche Anfrage / Wrong QuerySQL-Query = UPDATE web_domain SET `ssl` = 'n', `ssl_letsencrypt` = 'n' WHERE `domain` = 'example.com' -> 1143 (UPDATE command denied to user 'ispcsrv2'@'srv.domain.com' for column 'ssl' in table 'web_domain')

    I've search in the forum and it looks like the problem came up from an update I did!
    This problem show up if the "reconfigure permission on the server" question is not answered YES!!!
    I made an update!
    That's when I updated to the latest version 3.1.9 today and I DID reconfigure the permission = YES !
    I re-tried the certificate creation without any change to the error!

    I'm kind a stuck now, adding ssl is not working.

    Anybody have an idea on how to solve this?

    Thanks
    Spazio
     

Share This Page