Let's encrypt unchecked box !

Discussion in 'General' started by mariosigma, Jul 22, 2020.

  1. mariosigma

    mariosigma New Member

    I have several sites on my ispconfig which has been working fine for years, today i wanted to put a new site (new domain), except that when i activate Let's encrypt the box is unchecked after checking!
    i have updated "git-stable" but same problem !
    info : certbot was installed automatically by installing ispconfig 3.
    /var/log/letsencrypt/letsencrypt.log :

    Code:
     lineage = le_client.obtain_and_enroll_certificate(domains, certname)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/client.py", line 357, in obtain_and_enroll_certificate
        certr, chain, key, _ = self.obtain_certificate(domains)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/client.py", line 318, in obtain_certificate
        self.config.allow_subset_of_names)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/certbot/auth_handler.py", line 66, in get_authorizations
        self.authzr[domain] = self.acme.request_domain_challenges(domain)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py", line 213, in request_domain_challenges
        typ=messages.IDENTIFIER_FQDN, value=domain), new_authzr_uri)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py", line 192, in request_challenges
        response = self.net.post(self.directory.new_authz, new_authz)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py", line 709, in post
        return self._post_once(*args, **kwargs)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py", line 722, in _post_once
        return self._check_response(response, content_type=content_type)
      File "/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/acme/client.py", line 583, in _check_response
        raise messages.Error.from_json(jobj)
    Error: urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Error creating new authz :: Validations for new domains are disabled in the V1 API (https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430)
    2020-07-22 12:25:03,898:ERROR:certbot.log:An unexpected error occurred:
    2020-07-22 12:25:03,898:ERROR:certbot.log:The client lacks sufficient authorization :: Error creating new authz :: Validations for new domains are disabled in the V1 API (https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430)
     
    Last edited: Jul 22, 2020
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. mariosigma

    mariosigma New Member

    How to check certbot version and how to update ?
     
  4. ahrasis

    ahrasis Well-Known Member

    No need to check the version I think. Just run "apt remove certbot letsencrypt" and install certbot-auto as per latest Debian Perfect Server guide should do it, if that is the issue.
     

Share This Page