Let's Encrypt : Trying to get SSL on all subdomain (wildcard seems to not working)

Discussion in 'Server Operation' started by AlexisC, Oct 22, 2018.

  1. AlexisC

    AlexisC New Member

    Hello !
    I'm trying to have SSL work on all subdomain. On www and non www it works perfectly. I know lets encrypt support wildcard since many month but I dont know if i have missed something.

    In the SSL tab i have selected *.my_domain.fr and tried register/create certificate, but nothing work.
    Any help please ? Thanks in advance
     
  2. ahrasis

    ahrasis Well-Known Member

    LE supports wildcard ssl certs for domain via dns challenge while ISPConfig currently only supports LE ssl certs validation via webroot, and does not support via dns challenge as yet.
     
  3. AlexisC

    AlexisC New Member

    Thanks for your reply. Is there any way to fix that until LE support dns challange ?
    I have more than 20 subdomains
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    20 subdomains should be no problem in the current LE implementation in ISPConfig and subdomains get added automatically to the SSL cert of the site when you add the subdomain in ISPConfig for that site. So there is no need for a wildcard SSL cert until you reach 100 subdomains.
     
    ahrasis likes this.
  5. AlexisC

    AlexisC New Member

    You are right. Really i have more than 40 but it's ok to add them manualy.

    Thanks for your work, ISPConfig is an amazing work ! Where can we donate ?
     
    till likes this.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a donation button on the ISPConfig dashboard, but it might be that you have hidden it already if you don't see it there. The easiest way to support is is to buy an ISPConfig manual :)
     

Share This Page