Let's Encrypt Troubleshooting

Discussion in 'General' started by ChildOTK, May 31, 2020.

  1. ChildOTK

    ChildOTK New Member

    Hello all,

    What is the best way to troubleshoot Let's Encrypt/Certbot not working?

    Essentially I have a server with 2 domains that are already enabled and have certs. I've now tried adding a 3rd domain and am trying to enable Let's Encrypt however it never gets a cert, and the Let's Encrypt log in /var/log/letsencrypt.log is empty.

    I tried updating certbot by adding its ppa repository for apt and certbot is now on version 0.31.0. According to the github repo this is on version 1.5.0 now.

    How can we update certbot properly and work with ISPConfig again? Assuming the version is the issue.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. ahrasis

    ahrasis Well-Known Member

    0.31.0 is a certbot version and 1.5.0 is a certbot-auto version. Both should work fine with ISPConfig though.

    The link provided by @Taleman should help you get the necesarry info for troubleshooting the problems but you can check your letsencrypt log manually and see what may cause such faults.
     

Share This Page