Let's Encrypt - "old copy of letsencrypt-auto"

Discussion in 'Installation/Configuration' started by Neptun, Jul 22, 2019.

  1. Neptun

    Neptun Member

    Hello all,

    when i do something at control panel, which uses Let's Encrypt - i get this message, where i am not sure if it is ok to ignore or it need to be fixed?

    Code:
    Mo 22. Jul 14:04:03 CEST 2019 You are running with an old copy of letsencrypt-auto that does not receive updates, and is less reliable than more recent versions. The letsencrypt client has also been renamed to Certbot. We recommend upgrading to the latest certbot-auto script, or using native OS packages.
    Mo 22. Jul 14:04:03 CEST 2019 Saving debug log to /var/log/letsencrypt/letsencrypt.log
    Mo 22. Jul 14:04:03 CEST 2019 Plugins selected: Authenticator webroot, Installer None
    Mo 22. Jul 14:04:03 CEST 2019 Obtaining a new certificate
    Mo 22. Jul 14:04:04 CEST 2019 Performing the following challenges:
    Mo 22. Jul 14:04:04 CEST 2019 http-01 challenge for domain.eu
    Mo 22. Jul 14:04:04 CEST 2019 Waiting for verification...
    Mo 22. Jul 14:04:06 CEST 2019 Cleaning up challenges
    Mo 22. Jul 14:04:13 CEST 2019 finished.
    In total it is working and it is creating the certificate - i use latest stable of ispconfig

    Thanks in advance
     
  2. ahrasis

    ahrasis Well-Known Member

    I think it should be ok to ignore them.
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What is the version of Let's Encrypt or certbot on that host?
    If certbot comes with the OS and is updated from the OS, then I agree with @ahrasis, it is OK. If, however, you have installed certbot manually from somewhere else and thus it is not updated automatically, then you should check what version of certob you are running and if it is indeed too old.
     
  4. Neptun

    Neptun Member

    certbot version was 0.35.1 i haved updated it now - available was 0.36.0 - maybe this fixed the issue
     
  5. ahrasis

    ahrasis Well-Known Member

    That is just a mere info or warning, not real issues or errors, thus you need not be worried. If you keep attending all warnings like this, you'll be easily bought down unnecessarily. So far as the posted logs / messages are concerned, your certbot version is working fine. So my advise, only fix / update when it failed to work.
     
    Last edited: Jul 24, 2019
    Neptun likes this.

Share This Page