Lets Encrypt not remembering checkbox setting...

Discussion in 'ISPConfig 3 Priority Support' started by peterpetr, Aug 29, 2018.

  1. peterpetr

    peterpetr New Member HowtoForge Supporter

    I created a new Site checking the "Let's Encrypt SS: [x]" setting under the Domain tab.
    Redirect tab had "Rewrite HTTP to HTTPS: [x]" checked.
    Options tab has the following entries for WordPress support:
    Custom php.ini settings:
    display_errors = On
    post_max_size = 99M
    upload_max_filesize = 255M
    max_execution_time = 220
    memory_limit = 256M
    max_input_vars = 2000​
    nginx Directives:
    client_max_body_size 100M;
    location / {
    try_files $uri $uri/ /index.php?$args;
    }
    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;
    location ~* \.(jpg|jpeg|png|gif|css|js|ico)$ {
    expires max;
    log_not_found off;
    }​
    PROBLEM:
    After clicking [Save] and waiting for the red circle notification at the top to disappear, if I go back into the Domain tabe for this Site, the Let's Encrypt checkbox is UNCHECKED. I try checking and saving but the LE setting is NOT remembered.
    I need to make this a LE secured site so I can install WordPress using HttpS.
    Please help to resolve the above problem. Thank you.

    Server Info: Ubuntu 16.04, ISPconfig 3.1.13 (just upgraded from 3.1.12 today using default values in update script); nginx web server. I can view the new Site's default page ("Welcome to your website!") when using http://learn.NewSite.net/index.html
    [​IMG]
    https://www.screencast.com/t/TpU7mnC7Jy (screen shot shows result in browser)
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page